6

I have my birthdays stored in my contacts. As of late I see duplicate entries for each birthday in my Calendar on the Mac. On my iOS devices they only show up once. When I deactivate my contacts account (macOS Server account) the birthdays are removed from my calendar as expected. When I reactivate the contacts account the birthdays re-appear but only once. After a few hours Calendar on my Mac will then show them twice again. If I try to manually delete one of the events I get the error message: "You can't add or change events in the Birthdays calendar".

Is there a why for me to reset my "birthdays Calendar" on my Mac? What else can I do?

I am using the Sierra 10.12.2 and Calendar version 9.0

Thanks for any advice.

4
  • a couple of days later - the duplicates have now vanished... very strange.
    – Joseph
    Jan 22, 2017 at 12:33
  • Don't have birthdays checked in the sidebar or anywhere. Get duplicates of all birthdays of people who are associated with an email account from gmail. I have attempted to figure out what gmail is doing and that is a vampire time suck as well. The "Contacts" are the contacts from Apple Mail. The Gmail is where the "Contacts" are located for the calendar. There are four calendars. Each one has some information that is imported to the calendars. Each will show birthdays that turn on and off. The "Contacts" box when unclicked disappears. Clicked and there are two reminders. One actually reminder
    – TuckerDog
    Oct 15, 2018 at 21:24
  • One actually reminder is actually three. Twice for the person at the company and once for the company itself. Haven't a clue.
    – TuckerDog
    Oct 15, 2018 at 21:24
  • What's even better is I have a calendar from Auckland, NZ and if I click on it, I can change it to all sorts of strange locations in the world. Can't delete it. But can change it. And not ALL birthdays are duplicated. As I say, if I turn off iCloud (let's say it's pink) goes away, while the grey calender remains with two listings for the same person. If I click on that box, I can remove those two. I can even make the same person show up in the pink iCloud and the grey Contacts. But if I have the Contacts on, some are listed twice.
    – TuckerDog
    Oct 15, 2018 at 21:44

5 Answers 5

23

macOS Catalina (10.15.7)

Unchecking and renabling birthdays on the calendars sidebar will only toggle visibility and did not remove the duplicates, but unchecking and renabling 'Show birthday calendar' in the calendars settings seems to reload it - that's what worked for me.

4
  • 2
    I had 3 copies of each contact after linking contacts from my iCloud and Exchange accounts, and this fixed it for me. Thanks! Jun 16, 2021 at 9:13
  • Worked for me as well Apr 30, 2022 at 14:35
  • Worked for me on Monterey 12.6
    – Craig Otis
    Sep 14, 2022 at 14:30
  • Also works on Ventura 13.5
    – bobics
    Aug 14, 2023 at 4:06
1

I also had this issue once. If it only occurs on the calendar of macOS but not your iOS devices and you use a sync service like iCloud check this setting:

  1. On your Mac open Contacts.
  2. In the menu bar select "Contacts" > "Preferences…"
  3. Select "Accounts".
  4. Verify that all listed accounts are listed only once.
  5. To disable an account temporarily, select it and uncheck "Enable this account".

If you have identified the account that resulted you may remove it with the "—" button on the bottom left.

Let me know if this solved your problem.

4
  • 1
    Only have one account. Like I wrote, when I deactivate it the birthdays go away. When I reactivate it forst only single entries appear and after a while the duplicate entry then appears. This is for all birthdays btw.
    – Joseph
    Jan 17, 2017 at 17:27
  • Can you please confirm that you have only one account listed in both the Calendar app as well as the Contacts app on your Mac? Also, which sync service do you use? Do you store them on your macOS Server or is this the OS version you are referring to?
    – oa-
    Jan 17, 2017 at 17:35
  • I only have one calendar and contact account - yes. The iCal server I connect to is a macOS Server (v 5.2). There used to not be any duplicates. The only thing that changed between then and now was that I had to change the password for my user id. I have already tried removing the account entirely (both contacts and calendar) - no luck.
    – Joseph
    Jan 18, 2017 at 4:55
  • Just to add on this. I recently moved calendar and contacts from one google account to another and experienced this issue. I had duplicates even though the old account was disabled, but removing the inactive account solved the issue. It could be a caching issue, but I was not waiting to figure it out. tldr; Inactive accounts could also add to the "Birthday" calendar. Removing it fixed the issue.
    – nle
    Apr 16, 2018 at 7:59
1

I was suffering the same issue (under Yosemite 10.10.5 on this MacBook) and just now resolved it via iCal's "Calendars" sidebar by unchecking "Birthdays" and checking (ticking) "Contacts."

Note: I sync my calendar via Google Calendar, and --after years of resisting-- linked my Apple Contacts to Gmail. "Birthdays" in my iCal sidebar is at the very bottom of the list, right under "US Holidays."

Hope someone finds this helpful.

1

you may have duplicate contacts "On My Mac", as well as iCloud and/or Gmail...

2
  • This was the case for me: for some reason all my contacts were duplicated, unsure what caused it.
    – glhrmv
    Dec 27, 2019 at 12:37
  • Same for me. When I updated my MacBook Pro to Catalina, it duplicated every entry in Contacts.
    – SSteve
    Jan 7, 2022 at 21:41
0

I solved this problem turning unchecking and checking again "contacts" in System Preferences/Internet Accounts/iCloud. Hope this can help some way.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .