2

For a day now i can't boot my Mac El Capitan. It halts on this screen:

enter image description here

What I tried:

  • NVRAM reset
  • CommandR Disk Utility checked SSD, I can launch Terminal and browse the files on SSD
  • Reinstall OSX; reinstall finished, but when it restarted it gives same result as on pic above.
  • Apple Hardware Test app didn't find failure

Not sure if it's since an OSX software update. The loading bar goes fast as usual till ~70% then it slows down and goes to 100% in 2-3 minutes then nothing happens.

UPDATE: Verbose mode stuck at "pci pause: SDXC"

Any other fix to try? ty

  • Do you have an SD card inserted? – Allan Jan 17 '17 at 11:49
  • I had when it started, however removing it didn't help. Why? – zsitro Jan 17 '17 at 15:57
  • Because SDXC has to do with the SD card slot and it would be a logical place to start your diagnosis. – Allan Jan 17 '17 at 16:19
4

The problem is unsupported .kext files and you need to remove them to get OS X to boot. Just moving them to a different directy will have the same effect but will allow you to copy them back. This article had the solution for me: OS X El Capitan 10.11.x Hanging on Boot

mount -rw /
cd /Volumes/Macintosh\ HD/Library/Extensions/
mkdir Unsupported
mv *.kext Unsupported
reboot

After solving that issue, I ended up with a black screen where I could only see my cursor. If that happens to you, try the solution found here: Black Screen But Can See My Cursor

  • Just removing third party .kext files should be enough. – siniradam Aug 25 '17 at 6:51
0

The similar situation was on my Mac mini 2014: Mac OS (of any version, of any kind, including booting from installation flash drive or loading within the Internet recovery process) was showing the progress bar for a long time when loading, the progress bar moved slowly, reaches the end and nothing more happened.

After PRAM reset (Command+Option+P+R) Mac OS has been successfully loaded, but only for one time. For every next Mac OS load it was required to perform PRAM reset again. In addition, the loading took longer than usual.

In Single User Mode (Command+S) there was a message "pci pause: SDXC" when executing some commands, and then all stops.

And one more symptom: a delay of a few seconds between click on power key on the case and startup chime sound.

Everything was fixed by replacing the PRAM battery (this is a regular CR2032 battery). The loading speed was also regained back to normal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .