2

Since iOS 10.1, my iPhone often fails to send SMS. After sending, it waits, then display the red (!), saying "not delivered"

  • it seems to only happen on non-iPhone recipients
  • most of time (everytime??), my recipient still get my message (in spite of the not delivered warning)
  • someone told me "why do you always send your messages twice?".

How this correct this issue?

1

This could be down to people previously using an iPhone and having their number registered with iMessage, and then moving to a non-iOS device. In this case, your phone is still trying to send the message over the iMessage platform even though the recipient can't receive it. They can check and de-register here.

| improve this answer | |
  • hmmmmm... very interesting. But I know that many of the problematics contacts did never have any iphone. The kind of linux guys, you know :) – Martin Jan 16 '17 at 14:30
1

I think you have this problem, because you are using the same email on two or more devices. Anyway I will provide you with two methods, because i had a similar problem like yours back in the day.

  • Method 1: (not an universal fix)

Go to Settings > Notifications > Messages, turn off notification center

Then Go to Settings > Messages, turn off iMessage

Reboot the phone

Turn iMessage notifications back on, then turn iMessage back on, in that order.

  • Method 2: (if you are using the same iCloud account on two or more devices)

Go to: iMessages > Settings > Send & Receive > turn on all your phone numbers and email.

Most importantly, set "Start new conversations from" your phone number, not from your email addresses.

Good luck.

EDIT: If you update to the latest iOS version this problem will be fixed by itself.

| improve this answer | |
  • Thanks for your feedback. I updated my device before you sent this post. Now I only sent 2 sms with no problem, but it's not enough to tell. If the update to 10.2 works, I won't be able to test your two methods, though. – Martin Jan 16 '17 at 15:37
  • I am glad that I can help you. I forgot to mention that this "twice sending" can occur when you are in a low coverage area. I've managed to find another thing. Go to: Settings > Messages > turn off Send as SMS function. and another thing: Ensure that only your phone number is listed in the “You can be reached by iMessage at” area. If you have an email address or anything else listed, it could cause duplicate text messages. > Thats in the Send and Receive section. Good luck, Martin! – Adler Ademov Jan 16 '17 at 15:50
  • Turning off send as SMS means that if the iMessage fails to be delivered no message at all is sent. At least with that option on it will send it as an SMS after a few minutes. – Darren Jan 17 '17 at 7:15
0

Update to iOS 10.2 if you haven't done that. Then disable and enable iMessage, see if the problem persists.

| improve this answer | |
  • I'll try to update 10.2 you're right. I tried to disable and enable iMessage again, it does nothing. Il only happen on the "green bubbles", the ones which do not use iMessage service. – Martin Jan 16 '17 at 14:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .