1

I just upgraded to Sierra from Mavericks and since I did, the mirroring options icon is always in the menu bar. When I click on it, it says in grey: “AirPlay: Looking for AppleTV” then after a few seconds it will change to “AirPlay: Off”. I went to display preferences and the part that says AirPlay Display only has Off in the dropdown (which it is set to). I want that icon to go away, but I want it to appear if I plug in an HDMI cable or something so I don’t want to uncheck the box. Will my Mac look for an AppleTV now and forever?

1

If you don't want to connect to AppleTVs at all, you can disable the service that is constantly looking for AppleTVs:

  1. Disable macOS' System Integrity Protection (SIP):

Reboot your Mac and hold Command-R as soon as possible. Let go when you see the Apple logo. In the menu bar at the top go to Utilities > Terminal

Now we will disable macOS' SIP, disable AirPlay and re-enable SIP again so your Mac stays safe. Enter these commands

csrutil disable

sudo chmod 000 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent

csrutil disable
  1. Click the Apple logo in the upper left and select "Restart"

Your Mac won't display the AirPlay Mirroring icon if an AppleTV is near you.

Let me know how this worked out for you.

edit: To undo the changes use this command

sudo chmod 755 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent
  • Ok, thank you. I'll give that a try later. This seems like a bug but I don't know how long it's been around since I just upgraded from Mavericks. Is this a common issue do you think? – Steps Jan 17 '17 at 18:28
  • As far as I understand this is the intended behavior in macOS Sierra. Even when I'm not connected to a network this icon is visible on my MacBook. – oa- Jan 17 '17 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .