3

How can I go about changing the time that a banner notification stays on the screen before disappearing?

I did some research and tried the suggestion found here, but am having no success on my MacBook Air. I restarted and logged in/out of my account a few times after re-entering the command with no luck. Does this command no longer work?

5

You cannot easily customize the time anymore on current os since the preference has been removed since MacOS 10.10 Yosemite.

If you want your notifications to stay on the screen until you dismiss them, you can do the following:

Go to System Preferences > Notifications

Select the notifications you want not to be dismissed automatically. Change the "alert style" to "Alerts" instead of "Banners".

| improve this answer | |
1

I don't believe @oa-'s answer is correct.

I am running Catalina (10.15.2) and was able to get a slightly modified method to what is mentioned in the link from OP working just fine.

First, you need to specify -int before the number of seconds parameter:

defaults write com.apple.notificationcenterui bannerTime -int 2

Otherwise, it's written as a string which won't be recognized as valid argument for the number seconds.

Before it'll take effect, you'll also need to restart the NotificationCenter process by signing out/in or running:

killall NotificationCenter
| improve this answer | |
  • @oa- is right, this defaults option doesn't work anymore. I tried set it 10 but there's no difference at all. macOS version: 10.13.6. – Simba Apr 24 at 2:30
  • according this, for macOS 10.13 and below you need to leave out the "-int" flag from my example above as only 10.14 and later require it: osxdaily.com/2014/01/29/… – shbooms Apr 25 at 20:03
  • It doesn't matter if the -int is added or not. This very setting bannerTime is removed. This could be also confirmed by the comments from the link you provided. – Simba Apr 26 at 9:55
  • 1
    here is proof of it working on my system (10.15). I use it to change the bannerTime to 1 second and then to 10 seconds successfully: i.imgur.com/Dqn3dKx.mp4 – shbooms Apr 27 at 1:05
  • Thx for ur illustration. I tried it again with the same test from ur video. I also did killall NotificationCenter. It just doesn't work on 10.13. Shit. No matter with or without -int, the display time is unchanged. Sorry about the downvoting, I'm not able to revert it now. – Simba Apr 27 at 4:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .