I've searched and tried a lot of stuff but still can't get it to work.

I was able to use my seagate HDD properly last week but now it doesn't mount. I tried plugging it to a PC & another mac, it works fine on both. The reasons could be

  1. Updating OS to macOS Sierra
  2. Not ejecting properly
  3. Installed sims4 with wineskin

Things I have tried.

  1. From disk utility clicking on mount & first aid. enter image description here
  2. From terminal writing: diskutil mount disk2s1 & diskutil mount readOnly disk2s1 both resulted with this Volume on disk2s1 failed to mount If the volume is damaged, try the "readOnly" option
  3. From terminal writing: diskutil repairDisk disk2s1 & diskutil repairVolume disk2s1.
  4. Restarted mac in normal mode & safe mode.
  5. /private/var/log/install.log from here found some logs but don't know what to do with them. enter image description here
  6. Switch USB ports & retry.
  7. A couple of other things.
  • Does it mount in a different computer? Did you try the "readOnly" option in mount?
    – Allan
    Commented Jan 16, 2017 at 11:52

11 Answers 11


I'd recommend checking if fsck is holding your disk hostage upon connection. This was it for me.

Running ps aux | grep fsck revealed:

root 2587 7.3 0.1 4363584 21780 ?? U 10:56PM 2:22.54 /System/Library/Filesystems/exfat.fs/Contents/Resources/./fsck_exfat -y /dev/rdisk2s1

So the solution was a sudo kill -9 2587 (insert your PID instead of 2587) (or sudo pkill -f fsck). As soon as that ran, my Volume immediately mounted.

Oh the irony of fsck being the problem...

Addendum (surfacing from comments): Ideally, you're better off letting fsck run its course. Otherwise, you'll run into this the next time too.

  • 3
    Very ironic...As an extra note, you need to kill fsck each time you want to mount the disk. Commented Mar 21, 2018 at 4:35
  • 7
    @JaseWhatson yep. what I've found is that you have to let fsck finish successfully (it can take a long time, depending on disk size) before you can stop having to kill it every time. Commented Mar 22, 2018 at 16:43
  • 3
    thanks for the extra info...I was wondering about this, because once you kill fsck it only mounts in read only. Commented Mar 27, 2018 at 4:16
  • 9
    Best thing to do is just to wait until fsck is finished. Had to wait ~20 minutes for a 500GB external HDD. I think macOS could be more transparent though, about fsck needing to finish before your disk will be mounted and ready to use.
    – cseelus
    Commented Nov 14, 2018 at 1:59
  • 2
    this worked for me. Commented Nov 21, 2018 at 15:12

I had a similar issue. The external drive did not show in finder. I tried booting into Single User mode and ran all the fsck commands with no success.

The drive was detected but when it is plugged in fsck starts to execute and it seems to run indefinitely. In my case it looped around the Could not repair after 3 attempts" error but then it just restarted the tests again.

I was not able to kill the fsck process either, it just kept going.

Finally I downloaded the free version of DiskDrill and clicked on the Rebuild button. When doing that, Diskdrill showed me drive content. However I could not select mount in the Free version and could not pay 89$ for recovering a non-important drive worth 30$.

However, I found it interesting that DiskDrill could see content and offered me to mount the drive so I wondered if it had done something good. So I went back to Disk Utility that previously did not allow me to Mount the broken drive and tried to Mount again and now it worked. I think DiskDrill unblocked something.

After mounting, I was able to format the drive successfully.

I tried all other options I could find, using command line, disk utility etc and this was the only thing that unblocked the situation. So it seems tools like Disk Drill etc can accomplish more than what Mac OS offers and it might be worth looking into if you have this issue. In my case I managed to work around it with the free version in combination with DiskUtility but if you need to recover files you probably need the full version (I could see the drive content but since I did not care about it, I just formatted the drive).


I had a mac-system Volume not showing up in Disk-Util any more. (so my mac didn´t start any more) Somehow i managed to install OSX on a new Hard-Drive and plugged the old one external.

Linux was still able to mount my Volume. But couldn´t read my Pictures and Documents Folder, because of readonly Disk and no rights to read these Folders. So couldn´t change the rights to readable by anyone. So i couldn´t copy my Data to an other Disk ! (i didn´t want to pay DiskWarrior)

Then my only Solution was:

(first i created the Folder: /my/hfs with mkdir, and instead disk1s2 you should use your disk and volume numbers)

sudo /System/Library/Filesystems/hfs.fs/Contents/Resources/hfs.util -M disk1s2 /my/hfs removable readonly suid dev

I have solved this issue by moving everything in the hard drive to another computer. Formatting the hard drive and moving everything back.

If you're having the same problem Ariel's solution sounds reasonable. Let me know if that works out so I can accept it as the solution.


I've tried just about everything on every forum I read short of formatting my hard drive. I was able to save my data by plugging my hard drive into an older Macbook not using High Sierra. After the beachball went away after a while I was able to see and drag my folders to another external hard drive one by one. It took a few days because it was a 3T, but I was able to copy everything. Hope this helps!



  1. Open the terminal
  2. Install TestDisk brew install testdisk
  3. Run TestDisk as a super user sudo testdisk
  4. Run the scan, then select the "boot" menu to restore the NTFS boot sector

Although macOS Sierra should allow you to read NTFS drives natively, have you tried installing MacFuse? This always works for me.

You can get the latest version from GitHub. (Just download the .dmg and install)

This free utility will allow you to mount, read and write to NTFS disks.

  • 1
    Could you edit your answer to include how to install OSXFuse, and configure it to work with NTFS? (I couldn't see any reference to NTFS on the Github page).
    – John N
    Commented Jan 16, 2017 at 11:34
  • @John N, Download and mount the Installer DMG File (currently osxfuse-3.5.4.dmg) and then once mounted double-click the FUSE for macOS.pkg icon and follow through with the installer. Commented Jan 16, 2017 at 12:42

Your drive is not mounting because the file system is corrupted and it is not seeing it as a valid file system.

enter image description here

Most likely, your drive has or is in the process of failing. My suggestion is to use a tool like DiskDrill's free tools to see if there is anything recoverable. If it is and it makes sense to, then you can purchase a license to recover your data.


Disk file system corrupted, indeed. If the disk is dying or not good anymore is easy to see with a tool. Download DriveDx from binaryfruit.com (trial) and the recommended satsmart driver. Test the disk.


If your disk happens to be exFat and you unmounted wrongly, it's most likely that fsck process keeps it hostage for repairing.

You can run this command which will kill the process and unmount/mount the drive.

sudo pkill -f fsck


I had the same problem and I used this solution that I found here: https://support.wdc.com/knowledgebase/answer.aspx?ID=20789#highsierra

Just a word of caution - this solution involves erasing the drive, so please read the entire article before you take any action with your hard drive!

Hope it helps!

  • 1
    Welcome to Ask Different and thank you for your answer. :) Unfortunately, short answers such as this don't really provide enough detail or context to help many users. And, just providing a link isn't very helpful as it may no longer work in future. Instead, could you please edit your answer (there's an edit link below it) to include a summary of the content you're linking to? This will help preserve your answer for other users who may benefit in future.
    – Monomeeth
    Commented Jun 23, 2018 at 5:46
  • 1
    How does the information on the linked page differ from answers already given (reformat the drive)?
    – nohillside
    Commented Jun 23, 2018 at 11:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .