0

I've got a 2TB Toshiba USB drive which I have been using for my Time Machine backups. Since a few days this disk no longer shows up when I connect it. Already tried completely shutting everything down and rebooting, no difference.

  • When running Disk Utility, it's not there.

  • When running diskutil list, it's not there.

  • I can't mount it (there's no volume or anything to mount).

  • I tried both USB ports, with the same cable I always use (it has always worked fine on both USB ports before).

  • When looking in System Information, either in the Store or USB section, it's not there.

  • I have reset the NVRAM (previously PRAM) as well as the SMC.

  • I checked if fsck might be running while it's seemingly busy, but that's not the case. I also checked if VirtualBox was trying to filter the USB drive, also not the case (actually, VirtualBox is not running at all).
    (I found these two suggestions in a similar question)

  • It's not an NTFS drive.

However, when I reboot into Recovery Mode and look in the Disk Utility there, it does show up!

Also, when I connect the USB drive in OS X, it starts buzzing and spinning i.e. making the usual sounds as if it's working normally. Goes on like that for about half a minute and then stops.

Any advice? I'm convinced that 'something' was changed to my system configuration that's causing the drive not to show up, but I can't seem to find out what.

Would it be wise or safe to start in Recovery Mode again, and do a First Aid / Disk Repair from there? (I would really prefer if the data on this drive doesn't get messed up)

  • I had a similar problem with an external USB 3.0 hard drive and my new MacBook Pro. Under regular operation it wasn't visible at all but in recovery mode it was. I figured the drive had gotten corrupted, perhaps from being disconnected from the computer at an inopportune time. It was under warranty, so I erased it and returned it to the shop. Life is too short for flakey drives. – Michael Stern Jan 16 '17 at 0:50
  • @MichaelStern Fully agree, but if there's a way to get some data off this drive before replacing it, it would save me quite some hassle. I'm especially wondering because the drive does show up normally in Disk Utility when booting in Recovery Mode (with ⌘+R). This really makes me doubt if the disk is flakey, or if something is messed up in my macOS. – RocketNuts Jan 17 '17 at 9:04

You must log in to answer this question.

Browse other questions tagged .