1

I need to completely disable the S key, as my keyboard keeps pressing (and spamming) it without any user input and it's very annoying while coding. I need to completely ignore it (but allow external keyboards to input it).

Please help.

7
  • 2
    How about getting the keyboard fixed? – Allan Jan 14 '17 at 0:55
  • 1
    Based on some of your previous questions, it seems you've had ongoing issues of one type or another with your keyboard. In a comment to an earlier question you state your Mac is little more than 6 months old, purchased on February 21, 2016. Clearly you should get this looked at by Apple under warranty, rather than trying to disable the S key. – Monomeeth Jan 14 '17 at 1:05
  • Perhaps @Dev is at McMurdo Station or in the depths of the Amazon rainforest and can't easily get to Apple. Have you tried gently pulling up on the 'S' key to remove the keycap to see what might be under there? Even if there is nothing visible, perhaps just removing and replacing the keycap may fix it. – IconDaemon Jan 14 '17 at 1:31
  • @Monomeeth That was a software problem. This was a hardware one. Was. – Dev Jan 14 '17 at 2:16
  • Yes, I understood that, but my point is that unless Karabiner Elements (or some other software issue) is the reason for your S key problem, then it is a hardware problem and it would still be covered by warranty. Surely, a phone call or online contact with Apple is warranted? – Monomeeth Jan 14 '17 at 2:24
1

I have fixed the issue by using Karabiner-Elements to disable my built-in keyboard when an external one is connected. Gotta love those mechanical keyboards.

I will also consider getting my keyboard fixed when I can afford it (in terms of both time & money).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .