5

It is my understanding that Time Machine does not compress as it backs up and that it backs up everything (at least in default mode).

Why then is the space-used stat given by Finder re my external hard drive to which I backed up my iMac's (OS X 10.9.5) internal drive much lower/less than the same stat in re my internal drive from which I backed up. The difference is 354.39 GB on internal vs. 85.83 GB on external.

My first backup took only about 40 minutes, which surprises me - thought would be like 4 hours, so I am wondering if it was complete and successful. However, all the files on my internal do seem to be on the external, and I got not messages indicating that there was a problem. It has been backing up hourly since that initial backup without any problems apparently.

Shouldn't those stats be the same?

  • Do you want to say: the difference between disk usage (internal vs. external) is 268.56 GB? – klanomath Jan 11 '17 at 7:54
  • Are you excluding any directories from the backup? ("Options…" in the bottom right corner of System Preferences > Time Machine) – Timothy Mueller-Harder Jan 11 '17 at 8:24
  • 1
    Can you add some screenshots which show the source of these numbers? Makes it easier to understand what exactly you are comparing here. – nohillside Jan 11 '17 at 11:11
2

Time-machine does not back up your entire Harddrive. It excludes most of the OS files and backups to your internal harddrive. It is possible, that you didn't notice, that your data got accidentially backed up to your internal drive. You can check it as follows.

To see how much space those local Time Machine backups are consuming, click the Apple icon on the menu bar, click About This Mac, and click the Storage heading. The “Backups” category here represents your local snapshots.

You can disable that through the terminal: sudo tmutil disablelocal

Edit: It will then automatically purge the already created local backups

1

You may be excluding some content.

You can tell Time Machine to exclude one or more folders. Look at System Preferences > Time Machine > Options (button) > Private.

Some apps may indicate to Time Machine that files should be omitted from the backup. One example is the Parallels virtual machine app. Each VM file can be many gigs, so collecting a history of those would quickly swamp your Time Machine volume. So Parallels provides a flag you can set on each VM to ignore in Time Machine. This setting defaults to ignoring in Time Machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .