1

Every so often, when I open a new tab in Google Chrome and go to a site, the page appears with black squares where the content should be. The browser's UI is still visible, and when I mouseover where the links should be, the cursor changes from a pointer to a hand icon, but nothing on the page itself is visible. Any subsequent pages visited have the same effect, as does opening new tabs. Restarting Chrome gets rid of the problem.

This only happens intermittently, otherwise I'd add a screenshot.

I'm on the latest version of Chrome, it's been happening for months.

Chrome Version 55.0.2883.95 (64-bit)

OS X Sierra 10.12.2 (16C67)

MacBook Pro (15-inch, Early 2011)

1

There are a number of possible causes for this (e.g. an extension you have installed is running amuck).

However, the first thing I would try on your particular model of MBP is to turn off hardware acceleration in Google Chrome. To do this, follow these steps:

  1. Launch Google Chrome
  2. Go to Chrome > Preferences (or just press the command, keyboard shortcut
  3. At the bottom of the page, click on Show advanced settings...
  4. Look for the System subheading in the new settings that appear
  5. Uncheck the Use hardware acceleration when available option
  6. Restart Google Chrome

Unfortunately, since your issue is intermittent it may not be obvious if this has resolved the problem. But what I can say is that this fixes the problem for many users I've helped (especially on mid-2010 and early-2011 MBP computers).

  • That's very helpful thank-you - I'll try that and report back in a few weeks! – tomh Jan 12 '17 at 7:38
  • Definitely fixed it. No more black screens. Many thanks – tomh Feb 4 '17 at 9:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .