2

I have a MacBook Pro (Retina, 13-inch, Mid 2014, running OS 10.12.1) and a MacBook Pro (15-inch, Late 2008, running OS 10.11.6) connected to the same home WiFi network.

I am trying to use the Screen Sharing app on the 13" MacBook to connect to the 15" MacBook. The target MacBook has both Screen Sharing and File Sharing enabled. I am able to successfully connect file sharing using Finder > "Connect As..." and the name and password for the admin account on my 15" MacBook.

When I try to connect Screen Sharing, using either the "Share Screen..." option in Finder, or by entering the "Connect To:" field, the Screen Sharing app will hang on the "Connecting..." screen.

I have tried restarting both computers, but the issue persists. I have also attempted some suggestions for killing related processes, but these seemed to be for older OS versions since I was unable to find "NetAuthAgent"

I have tried different combinations of Screen Sharing preferences (ie: Scaling and Quality) which didn't change anything. When I do manage to connect, if I turn scaling on, the Screen Sharing window will go grey and I will need to reconnect to see the remote desktop again.

Of note: When the "Connecting..." window shows, the display on the target 15" MacBook Pro wakes from sleep, but the Screen Sharing app on the 13" Macbook will remain stuck and never display the remote desktop.

You must log in to answer this question.

Browse other questions tagged .