I executed

chmod go-rwx /

Command on my Macbook pro yosemite. Since then its not able to boot up. It just sticks at apple logo.

Things I have tried:

  • Mac repair > Disk Utility > Repair file permissions. Completed Ok.
  • Mac repair > Disk Utility > Repair Disk. Completed Ok.
  • Pressed (Cmnd+S) during boot > fsck -fy . The volume appears to be Ok.
  • Pressed (Cmnd+S) during boot > verified permissions of all folders inside the / with another mac book of same specs. All were same.

Am I only left with re-install ?

Ps: I got that command from here: https://stackoverflow.com/a/6419695

  • 2
    Why did you run that on the root directory? That was talking about setting permissions for an apache folder. You're likely borked. Commented Jan 10, 2017 at 14:15
  • 1
    I am betting you had to issue the command sudo chmod.... because only the root user can issue that command to that directory. This should have been a flag that you are doing something "dangerous."
    – Allan
    Commented Jan 10, 2017 at 14:34
  • I thought 'For each parent directory leading to your web root' included everything, including / Commented Jan 10, 2017 at 14:34
  • "For each parent directory leading to..." Not every directory leads to your web directory now, does it?
    – Allan
    Commented Jan 10, 2017 at 14:36
  • 1
    @AtulVaibhav when copying shell commands from the interwebs, copy them exactly. Don't modify them unless you know what you're doing. Typing sudo rm -rf / for example will delete your entire system. As Allan suggested, use sudo-requiring commands with care. Commented Jan 10, 2017 at 14:48

2 Answers 2


Assuming you didn't change ownership (users/groups) but instead only changed the permissions...

Try issuing the command:

chmod 1775 /


Here's how I fixed it:

  1. Boot into Single User mode. ( Press Cmnd+S during start up )
  2. Ran fsck -fy successfully.
  3. Mounted / in read-write mode using mount -uw / so that I can edit permissions on it.
  4. Executed chmod go+x /
  5. Continued system boot by typing exit, voila! it all worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .