6

After updating my macOS to Sierra I've started experiencing a strange bug. When trying to compress some stuff to a zip (via the Archive Utility) it pops up a new Finder window after each compression.

Here are my Archive Utility settings:

enter image description here

As you can see "Reveal archive in Finder" is turned off. I've also tried turning it on and off a few times, but result was always the same.

It started to happen after upgrading to Sierra.

My current macOS version is 10.12.2.

Is there any fix to this?

1
  • Change from the Preferences "Use archive format" from "compressed archive" to "Zip archive".
    – dante12
    Oct 27, 2017 at 12:08

5 Answers 5

3

After some experimenting, I finally found a solution of sorts.

Before I get to it, just a word on the Archive Utility preferences. As far as I can tell, the preferences on the lower half of the window no longer have any effect on the Finder's archive creation process. It may have in the past, but the Finder no longer uses Archive Utility for archive creation, only for expansion. For the record, Archive Utility is located at /System/Library/CoreServices/Applications/Archive Utility.app.

The problem arises from the Finder's desire to reveal the archive it's just created. If you are in column view and are viewing the contents of a folder, and want to compress that folder and do so like in the image below, the Finder may open a new window to reveal the archive because it doesn't want to lose your folder selection in the current window.:

enter image description here

If instead in column view, you select a file (it must be a file) in the same column as the folder, and then right-click on the folder you want to compress, like in the image below, the Finder won't open a new window (it will change your current file selection to the newly created file).

enter image description here

So far, that's the closest I've come to any kind of "solution".

1
  • 1
    That's kind of strange solution but seems to be working. But it's easier to close opened finders than do "this" :)
    – Makalele
    Mar 8, 2018 at 8:31
3

I know this is an old post, but I've had this annoyance for as long as I've used a Mac and compressed any files/folders.

Piggy-backing off of @NSGod's answer, having nothing at all selected before right-clicking a folder to compress also works.

Animated gif of Finder right-click menu folder compression

Making sure nothing is selected, I was able to compress a folder fine.

It seems that Archive Utility's preferences do not affect the right-click menu options at all—the above works with and without archive format set to Zip archive and Reveal archive in Finder checked or not checked.

Archive Utility preferences

1
  • It works! checked in MacOS Monterey.
    – Jerry
    Sep 3, 2022 at 13:56
1

Checking and unchecking the "Reveal archive in Finder" option in Archive Utility -> Settings didn't work for me either, until I killed Finder.

To do this open the Terminal and type in:

killall Finder

Then hit enter, which should reload the Finder windows. - If you are uncomfortable with the terminal, you should be able to just restart your computer.

Pre solution fiddles

I did some tinkering with the setting before I got it working.

Opened Archive Utility -> Settings

The "Reveal archive in Finder" option was unchecked, so I checked it and closed the Archive Utility for it to update.

Then reopened Archive Utility, unchecked the option, closed the Archive Utility again.

Then ran the killall Finder command in Terminal

1
  • 1
    killall Finder did the trick for me after checking and unchecking the "Reveal archive in Finder" option in Archive Utility prefs.
    – A Herrera
    Feb 14, 2020 at 0:45
0

I'm a longtime mac user... currently use macOS 11.6. Didn't have this issue until the last year or so. Has been frustrating. After searching for a solution, didn't find anything usable. Did find a quick and easy fix for compressing folders... display in List... finder will not create a new folder. I use the right click and scroll to 'compress'. Frustration... gone!

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – nohillside
    May 26, 2022 at 20:32
-1

Enabling and then disabling this option solves the issue for me on macOS 10.12.2.

1
  • Doesn't work. Try archiving a directory. It'll open new finder window.
    – Makalele
    Jan 26, 2017 at 11:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .