1

I will sometimes use iTunes to listen to my laptop's music library while on an airplane or somewhere else I don't have an internet connection, and thus I turn off Wi-Fi to save battery. I haven't had problems with it in the past, but I took several flights today and encountered an annoying alert that came up every time a new track started playing, letting me know that iTunes could not connect to the iTunes Store. The network is down or unavailable.

Screenshot of alert

Well, of course the network is unavailable, I turned it off!

  • None of my library was purchased from the iTunes store; my entire library is unencrypted mp3 files on my local drive (mostly purchased from Amazon).
    • These same files are all synced to my iPhone and play just fine on there in Airplane mode.
  • The files play as normal, but the above alert comes up every time a new track starts, and bounces the iTunes icon in the dock as well.
  • If I start iTunes with an internet connection and then turn the Wi-Fi off, I don't get the alert on every track. However, if I Quit iTunes and start it again with Wi-Fi disabled, I get the alert.
  • My last flight was in December and it didn't happen then, but I have automatic updates on and I suspect something may have changed in an update. I'm currently on macOS 10.12.2 and iTunes 12.5.4.42.

Is there any way to allow me to use iTunes with Wi-Fi turned off that doesn't give me the above alert every time a new track starts?

  • 1
    Have you tried to using Restrictions to disable access to the iTunes store? I haven't tried it myself so I didn't want to add this as an answer yet. – fsb Jan 9 '17 at 20:58
  • 1
    Try signing out from the Store in the Accounts menu. – IconDaemon Jan 10 '17 at 2:47
  • Unfortunately, neither of the above appear to get rid of the error for me. – bogardpd Jan 10 '17 at 3:45
1

Today I chatted with Apple Support who told me this is now expected behaviour, that iTunes looks for a connection. Not great.

I have recently moved to El Capitan and use iTunes 12.5.4, I too get this message even when I am offline.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .