2

I have configured the Hot Corners as shortcuts for "Put Display to Sleep" and "Start Screen Saver".

Both work as expected, but when the monitor stops, the Ethernet connection is lost and I'm forced to disconnect and reconnect the Ethernet adaptor from the laptop.

How can I solve this frustrating inconvenience?

  • Is wifi enabled and running on this laptop as well as ethernet? – IconDaemon Jan 9 '17 at 20:07
  • The problem is indipendent from wifi. I have this problem both with wifi enabled (and connected) and with wifi disabled. The only difference is that wifi never lose the connection. – Alessandro C Jan 10 '17 at 8:56
  • What kind of adaptor do you use? Ethernet <> Thunderbolt or Ethernet <> USB? What brand? – IconDaemon Jan 10 '17 at 13:14
  • Ethernet USB, it's an original adaptor. – Alessandro C Jan 10 '17 at 13:54
  • USB may be the culprit. Apple sells this adaptor in their stores. Don't try any non-Apple Ethernet <> Thunderbolt. My school tried several models from 3rd party manufacturers and they all failed miserably from dropped packets to no connections at all. Q: did this start happening after weeks/months/years of use, or has it never worked. Also: what model of laptop? – IconDaemon Jan 10 '17 at 14:06
2

It seems that you can stop this behavior by preventing your machine from sleeping after screen lock:

  • Open System Preferences / Energy Saver
  • Under Power Adapter, check Prevent computer from sleeping automatically when the display is off

Now my Ethernet connection stays connected!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .