1

I'm using my new 2016 12" Macbook as a "desktop" by connecting it to an external display, USB Keyboard/mouse and running it in "clamshell mode". Works beautifully except the display never goes to sleep. I was kinda figuring it would go to sleep just the same way the internal display does but it will stay on for hours if I let it. I did set up a hot-corner to sleep the display and that works fine but that means I always need to do it manually. How can I get this to work so that it acts normally? Do energy saver settings not apply to external displays?

1

As a first step I would reset both your NVRAM and SMC, as well as double check your Energy Saver settings.

Resetting the NVRAM on an early-2016 12" MacBook model

Follow these steps:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Resetting the SMC on an early-2016 12" MacBook model

  1. Shut down your computer
  2. Keep the power cable plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

Energy Saver Settings

You don't specify in your question how you've configured your Energy Saver settings, but you may want to double-check what you've actually set under the Power Adapter tab. I've come across many instances where MacBook users forget that there's two tabs you can configure.

  • I tred the SMC and PRAM resets and it didn't seem to make any difference. I don't think it's a technical issue preventing the display from sleeping, as I can make it sleep manually using a hot-corner, but rather the energy settings aren't applying to external displays. This may be by design, but I'm not sure which is why I posted here. My Energy Saver settings are defaults, and work as expected when being used as a laptop. – Joseph Toronto Jan 10 '17 at 14:54
  • The Energy Saver settings should apply to external displays unless the built-in settings of the display override these in some way. What model display do you have? The reason I mention checking Energy Saver settings is that presumably you have your MacBook connected to AC power when you're using your display, so I wanted to make sure that the settings under the Power Adapter tab are in fact what you think they are? I know that seems a bit obvious, but I've come across many users who just didn't realise this. Also, when you refer to Hot Corners, do you mean you're activating your Screen Saver? – Monomeeth Jan 10 '17 at 23:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .