3

I'm on MacOS 10.12.2. I want to use Preview to give a PDF presentation. But here's a screenshot:

fullscreen Preview

It's hard to see, but there's a scrollbar on the right and the bottom has space for a scrollbar but none is there? How can I get rid of these scrollbars, seeing as the entire page fits fine.

The same thing seems to be happening when the PDF first opens, so maybe that's a clue:

Preview on first open

  • A (IMHO preferable) alternative would be using Acrobat Reader for the presentation. There you can manually switch to Full Screen, and there will be no scroll bars etc, because the pages get scaled to fit the screen. This would prevent the need to fiddle with system-wide settings. – Max Wyss Jan 10 '17 at 9:36
  • I've got Acrobat DC and it's been a miserable experience using it for presentations---it's sloooow in general (just switching to different parts of the interface leads to a multisecond spinning wheel), and most importantly whenever I switch to a slide with a picture a little pop-up appears in the lower right about some sort of "optimization of scanned pages" that it's running; I've tried googling how to turn this off to no avail. Is Acrobat Reader for Mac any better than DC? – stackoverflax Jan 10 '17 at 12:14
  • It is helpful to make the PDF as feature-low as possible before adding the "bells and whistles" for effects in Full Screen view. You might even consider to use a copy of the document, and then set security to allow almost nothing. – Max Wyss Jan 11 '17 at 0:08
  • Let me guess, you have a Logitech keyboard. Do not you? – Yury Feb 25 '17 at 2:58
5

In  > System Preferences > General, set "Show scroll bars" to "When scrolling" (or, if you're not using a mouse, "Automatically based on mouse or trackpad"). The scroll bars will be hidden unless you scroll the document.

  • 1
    The "When scrolling" option works, thanks! I'd like to be able to have this just fixed always though, and setting it to "When scrolling" means that in, e.g. Chrome, I no longer have a scrollbar which isn't ideal. Meanwhile "Automatically based on mouse or trackpad" is what I had it set to and that gives the undesired behavior of a useless scrollbar (the one on the right, which scrolls a tiny bit despite there being nothing to scroll). – stackoverflax Jan 9 '17 at 10:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .