2

I have an issue where when I connect my iPhone (6S) to my PC via USB in an attempt to transfer photos, only some photos are displayed in the folders.

This isn't to do with the phone being locked (it isn't) or needing to tap the "Trust this computer" option on the iPhone when it is connected.

Some photos are displayed and I can copy them from the device to my PC, but some, which are clearly displayed in iOS Photos, simply aren't there when I browse the file structure under the (the phone's name) > Internal Storage > DCIM > 100APPLE (etc).

I've tried:

  • Resetting the iPhone
  • Restarting the computer
  • Using a different USB port
  • Connecting to a different computer

I can also see the photos in question on iCloud and I can download them from there, but the reason I want to get them from the iPhone is that I also want the .AAE files.

2

After much frustration, Googling and trial-and-error, I came to the conclusion that the photos displayed on my phone weren't actually on my phone, but were instead "optimised versions" of photos stored in iCloud and therefore inaccessible through the file structure when connected to my PC.

(It should be noted that the photos did not appear pixelated or blurry in any way in the Photos app on my phone, but the following solution worked which indicates to me that these were "optimised versions"):

  1. Navigate to Settings > iCloud > Photos on the iPhone
  2. If "Optimise iPhone Storage" is selected, you have solved your problem: this means that some photos appearing on your phone are in fact stored in iCloud
  3. Select the option "Download and Keep Originals" - this will ensure all photos are actually stored on your phone, meaning they will appear when connected to a PC via USB.

Note: You may find that selecting this option results in a message that your phone lacks the necessary capacity to download originals of all your photos. I had to work in stages, allowing my phone to download the originals which I then copied to my PC and deleted from my phone, creating more space for more originals to be downloaded.

You must log in to answer this question.

protected by Community Oct 9 '18 at 22:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .