I've been having troubles with iTunes : it was working yesterday morning, and after I restarted my computer it will no longer run, it just gives me an empty message box

enter image description here

and if I leave it for a moment an error appears:

enter image description here

The problem occurred when I was on a old version of OSX, so I updated to Sierra and to the newest version of iTunes as well, didn't change a thing. What I have tried :

  1. restart computer

  2. Install Sierra with iTunes 12.5.4

  3. Try to remove iTunes, I just have a message : iTunes can't be modified or deleted since Mac OS requires it

  4. Try and download iTunes from the Apple website : the available one was 12.4.3, so when I try to install it tells me a newer version is already installed and stops.

Any ideas ?

Thanks in advance.

  • 3
    Pro Tip:- Rather than Cmd/shift/3 for a full screenshot, if you use Cmd/shift/4 then tap the Spacebar & click in the window you want, you'll get a picture of only that window, with a nice drop-shadow too. I trimmed the existing shots for you.
    – Tetsujin
    Jan 7, 2017 at 11:12
  • 1
    @Tetsujin Oh my gosh best tip ever.
    – owlswipe
    Jan 7, 2017 at 17:05
  • There's a QA on it, all the alternatives - apple.stackexchange.com/questions/3822/…
    – Tetsujin
    Jan 7, 2017 at 17:14

1 Answer 1


Exploratory troubleshooting: try holding the Option (or Alt) key down while you launch iTunes. Hold it until you see the following:

Choose iTunes Library

Now press "Create Library…" and see if you have any more success.

As a second option, try creating a new user on your system and see if iTunes works any different/better there.

These are steps to help you determine if the problem is the iTunes application or if it's something specific to your user account and its data.

  • Thanks for answering me. I tried holding the alt key but I have the same result
    – LMT-PhD
    Jan 7, 2017 at 19:42
  • Have you run a quick Malwarebytes' Anti-Malware (MBAM) for Mac scan? Jan 7, 2017 at 20:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .