11

Every time I restart my computer, it tries to "add a new helper tool". For instance I have to reinstall shell commands in Atom on every restart, and it prompts with the "An update is ready to install." But I see this same issue with other programs too.

Atom installs /usr/local/bin/atom -- but then when I restart it's gone.

I get the same thing from MAMP that it "wants to make changes".

And Slack gives me the same thing as Atom on every restart:

Slack is trying to add a new helper tool.

An update is ready to install. Slack is trying to add a new helper tool.

Enter an administrator's name and password to allow this.

Add Helper

Let me know what other information I can give.

  • Removing and reinstalling the app should also fix it. – maxhodges Oct 2 at 5:27
10

Try changing the ownership of Atom.app. In my case, Atom.app was found in /Applications, and ownership was:

drwxr-xr-x 3 1699963712 365896978 102 Dec 8 12:48 Atom.app

I ran the following command:

sudo chown -R $USER:wheel /Applications/Atom.app

In my case, any program with ownership of root or the numeric code listed above would have a popup a few seconds after opening. Changing ownership of the .app directory corrected the behavior and I don't see it anymore.

I found the information at this site.

| improve this answer | |
  • Do you know why this app was owned by root in your case? – cubuspl42 Jun 3 at 15:01
  • @cubuspl42 No, I don’t. And I no longer have access to the machine to check. – Leatherwing Jun 3 at 16:25
  • the "numeric code" above is a result of an unpacking of an application that had a UIDnumber that did not match a UIDnumber in the local user account database on the system. This is not uncommon, but in this case, Slack's helper appears to want to make changes to the files, and would ask for permission for each file to make changes too. I suspect an installation tool (either from IT or from slack) unpacked the archive with the preservation of ownership, leading to the issue? – cgseller Aug 26 at 12:25
1

Searching for the application and manually dragging it into the Applications folder also worked for me.

| improve this answer | |
  • 1
    that makes sense, but unfortunately it wasn't my issue, the app was already in there – Ryan Taylor Jun 22 '17 at 20:14
1

I had this annoying issue with Skype. The solution was:

  1. Enable root on MAC: https://support.apple.com/en-us/HT204012
  2. cd /Library/PrivilegedHelperTools
  3. su root This step requires login with admin privileges
  4. rm com.skype.Helper
| improve this answer | |
  • Could you just run sudo rm /Library/PrivilegedHelperTools/com.skype.Helper without enabling root? Your answer is helpful though. – Ryan Taylor Jan 22 '18 at 19:39
  • 3
    Enabling the root user on a Mac can open major security holes, especially for end users. If you need to use the root user by command line, I recommend using an administrator user, typing sudo su to switch to root. It will ask for a password. – juniorRubyist Feb 11 '18 at 2:24
  • For me the file was named com.skypinstaller... – James Mar 5 '18 at 20:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .