0

This question already has an answer here:

Using the Mac terminal whenever I hit enter, regardless of shell it outputs the line with square brackets. The issue doesn't occur in iTerm2.

Dan@Mac ~                                                            [10:32:55] 
[> $                                                                            ]

Dan@Mac ~                                                            [10:36:11] 
[> $                                                                            ]

Dan@Mac ~                                                            [10:36:11] 
> $     

So above is what there term looks like, input goes at > $ however on enter it shows with [> $.

Any advice appreciated, let me know if you need any other details.

edit: To clarify as this was marked duplicate of another thread which asks the functionality/purpose of mark, when posting this I did not know what mark was or that it existed.

marked as duplicate by grg macos Jan 6 '17 at 11:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Found the reason, in the terminals settings under edit there is an option called mark.

Seems this is designed to mark the prompt line, once disabled this behaviour stops.

Not the answer you're looking for? Browse other questions tagged .