2

My company bought an iMac for an employee. After 6 years, that employee is no longer with us, so I am trying to re-install the OS. I have done this with Windows and Ubuntu many times.

Here's the problem: I restarted the computer per some YouTube video, holding Command+R. This worked and I got into some admin help screen.

I clicked "Re-install OS X" which required me to connect to the internet (ok, fine). Then I had to sign in with some Apple ID (ok, fine). But then I kept getting an error message that "this account hasn't been used in the app store" or some kind of thing. After a while of reading advice, I found out I had to install iTunes on my own computer, then update the billing info.

I repeated the install process. That worked to get past the "this account hasn't been used in the app store" error. Then a new error that there was some connection issue with the App Store for my Apple ID (ok, fine--that happens). An hour later, it seemed to be able to connect.

A new error: "This item is not available right now. Please try again later." After another forever of reading, I found out that I was supposed to set up iCloud for some reason, and this would fix the error. It did.

I re-do the installation process for the 34293rd time and some random error I can't remember. So I close the Re-Install OS X application and open the "Help?" one. It says, "Hey--just re-format the disk and install." So, I did that and now there's a blank disk, and the OS still won't install because that is "unavailable" for some reason.

I have all the original items: keyboard, mouse, OS Installation Disk, Application Installation Disk, some papers, and the original box. There is an Apple Store 45 minutes away and this iMac is 27" so I really, really don't want to spend hours doing that.

For the love of God, what am I supposed to do to re-install the OS?

P.S. I have tried booting from the install disk, the HDD (before it was formatted), and using recovery by booting with Command+R.

Update

So, I tried the suggestions in the (at the moment) only answer here. They were actually pretty helpful and got me through some errors. Nonetheless, there were another half dozen issues (eliding quite a few hours here):

  • At some point it stopped letting me boot into the firmware screen (seemingly randomly).
  • At that time, each time it powered on it defaulted to "Reinstalling over the Internet". I let that run its course for a while --twice-- and the conclusion of that was the message, "The system cannot be restored over the internet" (or equivalent, I don't recall the exact wording at the moment). There was no apparent ability to log in with my Apple ID or anything, so that was that =)
  • I managed to boot from the original installation DVD. After running through the installation process there, the conclusion was: "OS X cannot be installed on this device."
  • I called a friend who uses only Macs for many years and he gave me some tips.
  • I tried a few utilities to create a bootable USB drive, but I couldn't get the iMac to recognize the USB drive as bootable (though Disk Utility did recognize it exists on 3 out of 4 boot attempts).

Conclusion

In the end, I created an Ubuntu live cd (v16.04x64). It took maybe 3-4 minutes to burn the DVD, booted and installed in about 5 minutes and looks & feels great on the nice screen and beautiful hardware. C'est la vie.

Side note: In the Linux paradigm, the OS doesn't follow the user or the machine. Just install it whenever, wherever.

  • What happens if you reboot with the installation disk? – nohillside Jan 6 '17 at 8:47
  • It boots up to an apple icon, then there's a spinner under it that hangs (seemingly indefinitely). I let it spin for several hours (maybe 3?) with no change. – Sir Robert Jan 6 '17 at 14:43
4

This isn't really an answer right now, it's a selection of possibilities which need testing &/or confirmation they've been tried & failed.

While there was still an old OS on the machine, Cmd ⌘ R should have run Recovery which would give you the opportunity to re-install the current OS, providing you could supply the Apple ID credentials initially used to 'purchase' the OS on that machine. Otherwise you would get the 'not available right now' issue.

This is where the paradigm differs from MS Windows. With Windows the OS belongs to the machine & you have to ring MS to move it to another, but not to reinstall on the same machine. With Apple the OS [& many apps work this way too] is owned by the person & can be freely moved or re-used, but not transferred to another owner.

Assuming the machine has at some point in the past had the necessary firmware update [that machine was first released right on the cusp of this technology] then if either the Recovery partition fails [or has been erased] or you hit Cmd ⌘ Opt ⌥ R at boot, then it will go into Internet Recovery mode rather than local.
This will allow you, without any Apple ID sign in, to download & install the OS that was first shipped with the machine - in this case 10.6.6.
From there it would be a two-step process to update to Sierra, as you would first need to instal El Capitan.

A third alternative is to boot from the original CD/DVD - hold C at the boot chimes which will launch an older version of the setup process.

Your last alternative, as you suspected, is to take it to an Apple Store, who will do it for you.

  • 1
    Thanks; that makes sense about the paradigm of attachment of the OS to the user vs. machine. I will try your suggestions and report back with either success or failure. – Sir Robert Jan 6 '17 at 14:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .