1

Recieved the error: 'Your screenshot could not be saved. You don't have permission to save files in the location where screenshots are stored.' with OS X Yosemite.

I opened terminal and tried directing the screenshots to save on my desktop:

Brigittes-Air:~ eggsalad$ defaults read com.apple.screencapture location 2017-01-06 03:04:47.765 defaults[17729:1947540] The domain/default pair of (com.apple.screencapture, location) does not exist

So I tried writing and:

Brigittes-Air:~ eggsalad$ defaults write com.apple.screencapture location ~/Desktop 2017-01-06 03:05:08.652 defaults[17742:1948451] Could not write domain com.apple.screencapture; exiting

I'm not sure where the screenshots are being stored if the location does not exist. Ideas?

EDIT

I ran something else and got a different response, but defaults are still unchanged.

Brigittes-Air:~ eggsalad$ defaults write com.apple.screencapture location/Users/eggsalad/Desktop killall SystemUIServer

2017-01-06 03:22:35.444 defaults[18265:2001767] Unexpected argument SystemUIServer; leaving defaults unchanged.

2nd EDIT Result of: ls -l ~/Library/Preferences/com.apple.screencapture.plist

was:

ls: /Users/eggsalad/Library/Preferences/com.apple.screencapture.plist: No such file or directory

  • To answer your last question, sounds like they're not currently being saved anywhere. But a Spotlight search for a file called '2017-01-06 03:04:47.765' would tell you for sure. – calum_b Jan 5 '17 at 16:21
  • Yeah, I'm aware they're not saving- so that file doesn't exist . – brigitte Jan 5 '17 at 16:28
  • Can you please run ls -l ~/Library/Preferences/com.apple.screencapture.plist and add the result to the question? – nohillside Jan 5 '17 at 17:43
  • @patrix Tried, added result. – brigitte Jan 5 '17 at 18:42
  • Hmm, ls -ld ~/Library/Preferences as well then, please – nohillside Jan 5 '17 at 20:05
2

You may have just gotten the commands wrong. Try

defaults write com.apple.screencapture location /Users/eggsalad/Desktop

make sure to press Return, then

killall SystemUIServer

and press Return again.

Then run

defaults read com.apple.screencapture location

As a last resort, just reset all the settings for your user:

 defaults delete com.apple.screencapture
  • 1
    I tried the first command and it unfortunately responded with the same Could not write domain com.apple.screencapture; exiting – brigitte Jan 5 '17 at 17:33
  • I’ve added a reset procedure here @brigitte - instead of writing over a value - just clear all the defaults for this app to get back to the standard settings. Much simpler and shorter command. This helps for other things too like when it copies to the pasteboard instead of writing the file to storage: apple.stackexchange.com/questions/328060 – bmike Jun 17 '18 at 21:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .