Is there a way to completely disable mouse clicks while typing (including from external trackpads)? The old option 'Ignore accidental touches while typing' which is apparently enabled by default now does not seem to do anything at all. I'm using MacOS 10.12.2 on a 2016 MacBook Pro, and I have tap-to-touch turned off.

3 Answers 3


Agreed the setting on by default does not actually disable the trackpad. It just tries to be "smart" about it, ignore accidental touches.

The only way that I have found is enabling "Mouse Keys" in System Preferences > Accessibility > Mouse and Trackpad. Check the "Enable Mouse Keys" checkbox. When it is enabled, you can disable/enable the trackpad by pressing the option key 5 times.

It is not really a full solution, but between that and the "Disable trackpad when external mouse or trackpad is present" option it is as close as it gets.

You can also increase the resistance of the click of trackpad in the Trackpad settings in System Preferences which may help.

  • Hmm yeah I saw the Mouse Keys hack elsewhere but it's not a great solution. I wonder if it is possible to write a program to do this. Does Apple provide enough API access?
    – Timmmm
    Jan 5, 2017 at 15:26
  • 1
    Not that I know of. The only way of disabling the trackpad, I have found outside of the above, is unloading the trackpad kext, which also disables the keyboard. So no bueno. Jan 6, 2017 at 18:51
  • The MouseKeys hack is completely without value if you're typing on a keyboard that lacks a numeric keypad. My external keyboard—and obviously my laptop keyboard—both lack a numeric keypad. I'd guess that 90+% of users don't have a numeric keypad.
    – iconoclast
    Nov 10, 2017 at 17:23
  • @iconoclast, I fail to understand why MouseKeys necessitates a numeric keypad? Am I missing something? Nov 29, 2017 at 21:38
  • @natemacinnes: Mousekeys does not necessitate a numeric keypad, but using Mousekeys as a way to disable a trackpad while you're typing necessitates a numeric keypad because some keys have to be used for mouse movement, and if you use the main keyboard for mouse movement then you can't use it for normal typing.
    – iconoclast
    Dec 1, 2017 at 18:42

The best way to do stop accidental touches is to disable Tap to Click in e.g. MacOS Big Sur trackpad settings.


An information that I read at some point on the internet, I don't remember where (not on the Apple website): if you rest your hand on the trackpad while typing, macOS is smart and ignores their movement.

In fact, typing does not matter. Try to do a gesture, any gesture, using the palm. It does not react. A palm and a finger produces the regular mouse moving, like the palm is not there. The same for gestures involving more fingers.

Since your fingers are on the keyboard and you touch the trackpad only with your palms, their movement does not produce clicks or moves of the mouse cursor.

Apple has solved the problem some time ago (maybe this is the reason why they removed the "Ignore accidental clicks while typing" setting), they just forgot to make the information public somehow.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .