0

I was in the midst of attempting to setup the built in apache webserver to do some light network file sharing to my iOS device that I didn't wish to sync, discovered that I can only access network related stuff from the machine itself and no other device on the network except the router can seem to discover the machine.

For example, I can access the built in webserver via it's IP and localhost (as well as *.local) if I do it directly on the same machine. If I try to access the webserver using the IP address or the .local address from my iPhone connected to the network, the page times out. I also cannot seem to ping the machine from my iPhone either, however when I ping the machine from the router, the router gets a response.

I also attempted to try installing MAMP and use the :8888 setting for Apache but it still can't be resolved from anywhere else on the network other than from the machine itself.

Curiously, I also cannot ping my iOS device from the macOS machine, only from the router. But, if I use canyouseeme.org to check if my running torrent app's forwarded port is working, the website is able to connect to the app on my machine.

The only thing to note is that both the iOS device and macOS machine are both on the latest beta versions available.

I do not feel as if this is a router issue as I've used the .local and IP address just fine to access previously configured apache setups on previous OS X versions. With most updates, it seems to reset the server configs and as such I have had to restore the settings. Up until now, this process has been working fine. I don't understand why this isn't working now, possibly a bug in the beta?


IP-addresses:

macOS Machine: 192.168.1.5
iPhone: 192.168.1.3

  • I added the local IPs of both devices. Is there any other info needed? I'm not new to basic networking and server setups, I just have a feeling this is a shared bug between macOS and iOS at this time. – cmdshft Jan 5 '17 at 5:26
  • Your router shouldn't be involved (as a routing device) because both Apple devices are in the same network (prob. 192.168.1.0/24). – klanomath Jan 5 '17 at 5:35
  • Right, and I've made zero changes to the router settings and zero changes to both devices wifi settings. Previously, this worked fine. I think this is a bug on both iOS and macOS since they are both on beta OSes. – cmdshft Jan 5 '17 at 5:38
0

I believe I found a solution.

It appears that there may have been a change by Apple in how the Bonjour service handles router security.

I had changed my router to WPA2 due to needing to use the built in recovery system in the macOS bootloader, as it was not functional with WEP security.

I happened to notice that my AirPrint printer was no longer being seen on the network as well and I also couldn't ping it, so I changed the security back to WEP to test and Bonjour services started working again. I was able to print as well as access the apache server from my macOS machine from the iPhone across the network with the .local name.

Not being happy with having to use WEP again as it's far less secure than WPA2, I went about looking for a solution.

I have an Actiontec router used for my FiOS setup. It's a MI424-WR revision C with Firmware 4.0.16.1.56.0.10.14.4

Logged in and changed the following option: Advanced -> IGMP Proxy -> Enabled

enter image description here

Bonjour services appear to be functioning properly now with WPA2 enabled. Apache server, AirPrint, Remote.app, etc. All work fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .