3

I want to disable the trackpad on my laptop without a mouse connected. I need this strange functionality because I use synergy (https://symless.com/synergy/) and game with my desktop.

This is what I have tried so far,

kextstat -kl | awk '{print $6}'| grep -i multi 

which gave

com.apple.driver.AppleMultitouchDriver 

Thus I went ahead and ran

sudo kextunload -b com.apple.driver.AppleMultitouchDriver

which gave the error

(kernel) Can't remove kext com.apple.driver.AppleMultitouchDriver;    services failed to terminate - 0xdc008018.

Failed to unload com.apple.driver.AppleMultitouchDriver - (libkern/kext) kext is in use or retained (cannot unload)

To be sure, I also tried another way (which was floating around stack exchange)

sudo kextunload /System/Library/Extensions/AppleMultitouchDriver.kext

which produced the same error message.

Thanks in advance! I am a new user so please excuse my poor formatting.

For reference, I am using Sierra and the latest version of MacBook Pro 13 inch (no touchbar).

In addition, these are the links I have looked at,

  1. https://superuser.com/questions/606338/how-to-disable-trackpad-mouse-via-the-mac-os-x-command-line
  2. https://discussions.apple.com/thread/5240707?start=0&tstart=0
-2

I resolved this issue by resetting the PRAM on my MacBook.

How to reset NVRAM/PRAM

  • The question is asking how to perform a task, not how to "resolve an issue". – duskwuff May 26 at 18:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .