0

I originally came across this post with a possible answer but, I do not understand how to go about the process, especially when 2 drives are both not showing there full size. This originally happened when I had Ubuntu Gnome installed alongside OS X (one drive (SSD)). I have dedicated the SSD to my OSes and the other HDD to my home folders.

When I attempted to delete the Linux partitons (one on each drive) they are now completely gone out of sight. I am unable to regain that space to add it to my system and home partiton on the drives.

Both are 500 GB drives but only 250 GB are used. I have a mid 2012 MacPro

(Incase your wondering how I have 2 drives in this mac I replaced my optical drive with a hard drive caddy)

When trying to read the gtp/pmbr scheme this is what it spits out disk0 is osx disk1 is home.

  zackerys-MacBook-Pro:~ gefiltefish1478$ sudo gpt show disk1
Password:
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  488050672      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  488460312       2024         
  488462336     260096      3  GPT part - 0657FD6D-A4AB-43C4-84E5-0933C84B4F4F
  488722432  487790592         
  976513024     260096      4  GPT part - 0657FD6D-A4AB-43C4-84E5-0933C84B4F4F
  976773120         15         
  976773135         32         Sec GPT table
  976773167          1         Sec GPT header
zackerys-MacBook-Pro:~ gefiltefish1478$ sudo gpt show disk0
       start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640   499902768      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
   500312408     1269536      3  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
   501581944   498372488         
   999954432      260096      4  GPT part - 0657FD6D-A4AB-43C4-84E5-0933C84B4F4F
  1000214528         655         
  1000215183          32         Sec GPT table
  1000215215           1         Sec GPT header

disk1

and both drives show somthing like this

This is the output when I run df.

df
Filesystem                       512-blocks      Used Available Capacity iused      ifree %iused  Mounted on
/dev/disk0s2                      499902768 130185800 369204968    27% 1249077 4293718202    0%   /
devfs                                   375       375         0   100%     651          0  100%   /dev
/dev/disk1s2                      488050672 465813600  22237072    96%   89020 4294878259    0%   /Volumes/HOME
map -hosts                                0         0         0   100%       0          0  100%   /net
map auto_home                             0         0         0   100%       0          0  100%   /home
localhost:/KJdZJAu-3rlfljye4LGYtx 499902768 499902768         0   100%       0          0  100%   /Volumes/MobileBackups
/dev/disk1s1                         403266        15    403251     1%       0          0  100%   /private/var/tmp/MP4XJX8Y  

I'm extremely wary about rewriting any GPT without someone else's input. Needing help; I know @klanomath was able to fix this issue hopefully he can have some input on my situation. Possibly someone can make a bash command line to automate the process for other users who may encounter the issue.

Possible future GitHub project if I figure out how to do this on my own.

13
  • This question is very difficult to read. Can you please add some punctuation and adjust the formatting? That will help people understand your issue and try to suggest fixes.
    – fsb
    Jan 3 '17 at 17:25
  • @fsb Yes, my apologies. I have edited it; in desperate need of help.
    – NEXTCODE4U
    Jan 3 '17 at 17:37
  • What exactly are you asking?
    – Allan
    Jan 3 '17 at 17:47
  • Disk0s3 has the wrong partition type: it should be 426F6F74-0000-11AA-AA11-00306543ECAC. Everything else looks ok. To regain empty and continuous space to expand your OS X partitions you simply have to delete disk1s3 and disk1s4 as well as disk0s4 (all Linux remnants).
    – klanomath
    Jan 3 '17 at 17:49
  • @klanomath Ive tried deleting the partitions (in osx and recovery) but i get "MediaKit reports partition (map) too small. If you recently grew your whole-disk, you should run whole-disk repair." On disk0 and "Couldn’t read partition map." on disk1. Is there any other data I could post to help diagnose the issue.
    – NEXTCODE4U
    Jan 3 '17 at 17:56
1

Your disk contains some blocking Linux swap partitions: disk1s3, disk1s4 and disk0s4 (all partitions with the type 0657FD6D-A4AB-43C4-84E5-0933C84B4F4F). Additionally your probable Recovery HD disk0s3 has the wrong type: it should be 426F6F74-0000-11AA-AA11-00306543ECAC.

Depending on your Mac model either use Internet Recovery Mode or a bootable OS X installer thumb drive to "repair" your disks.


Since your user folder resides on a different partition create a safety net admin user first on your boot disk. Log-in as second admin user to be sure that the account works independently from your main admin user.


  • Boot to Internet Recovery Mode (or the thumb drive)
  • Open Terminal in the menubar > Utilities
  • Enter diskutil list to get an overview.
  • Use the disk identifiers of your SSD and the HDD (e.g disk0 and disk1) enter gpt -r show disk$.

    Below I assume disk0 is your system disk and disk1 is your HOME disk.

  • Unmount both disks with diskutil umountDisk disk0and diskutil umountDisk disk1.
  • remove the two swap partitions on disk1:

    gpt remove -i 3 disk1
    diskutil umountDisk disk1
    gpt remove -i 4 disk1
    
  • remove the Recovery HD and the swap partitions on disk1:

    gpt remove -i 3 disk0
    diskutil umountDisk disk0
    gpt remove -i 4 disk0
    diskutil umountDisk disk0
    
  • re-add the Recovery HD with the proper type:

    gpt add -i 3 -b 500312408 -s 1269536 -t 426F6F74-0000-11AA-AA11-00306543ECAC disk0
    
  • resize both main volumes with:

    diskutil resizeVolume /dev/disk0s2 100%
    diskutil resizeVolume /dev/disk1s2 100%
    
  • Verify both volumes with diskutil verifyVolume disk0s2 and diskutil verifyVolume disk1s2. If necessary repair the volumes.
  • Reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .