1

To slightly rephrase the question, should it be necessary to disable HD sleep in the Energy Saver pane as a means to maintain a live wi-fi connection as the computer becomes idle and enters sleep?

Here's what prompts the question: I am attempting to make use of the open-source "Hermes" and the App Store "HD Radio for Pandora" to stream music. Everything is fine until I walk away from the computer. Shortly thereafter, usually about 7-12 minutes later, the Pandora app will get through the last song in the buffer and cease playback. When I return to the MacBook the System reports that the app has crashed. Each of the stand-alone Pandora apps I've tried has produced the same crashlog results. The log cites the main apple thread, another containing the words "Audio toolbox" and a remote/sharing process.

I have reinstalled El Cap over the existing install after a lot of effort to troubleshoot, including renewing the DHCP lease, uninstalling my antivirus protection, trashing Power Management, Bluetooth, sharing, wi-fi and system config prefs, turning off file sharing, etc. Despite reinstalling the OS, the problem remains.

I don't have issues staying connected to wi-fi as a rule, and another Mac on the same network runs these same apps under Snow Leopard and El Capitan, respectively, with no issues streaming audio while idle/sleeping. The disconnect/crash problem occurs consistently, however, on my mid-2012 MacBook Pro whether on a wired (ethernet) connection or wi-fi. I'm not sure what other troubleshooting steps to take to enable either one of these Pandora apps to work. Any pointers will be much appreciated!

  • If you keep the screen awake does it still happen? Does it happen on screensaver, or only at screen-off/sleep? – Tetsujin Jan 3 '17 at 10:28
  • I will see about disabling the screen saver. I hadn't noticed if that was a factor or not. What I do know is that if I allow the Display to sleep (default) but I select "never" for the computer sleep it seems to solve the problem. However, that workaround seems like overkill. I'd rather not alter Energy Saver defaults but it seems this is the only workaround I've come up with (to disable computer sleep). My last resort is to wipe the entire HD and do a clean install of El Cap but I'm trying less drastic solutions first. – NewsView Jan 3 '17 at 21:37
  • Update: I verified that the screen saver is set to "never", although it still loads a screen saver if I trigger a "hot corner" (even though it is set to "never"). For what it is worth though, I don't see a screen saver prior to the display sleeping. If I disable the login screen and watch the desktop load after wake I can watch the Pandora app quit unexpectedly just as soon as the wi-fi reconnects. So it seems as if the audio streaming terminates while the computer sleeps but the Pandora apps are still loaded until wake, at which point waking the computer triggers a crash. – NewsView Jan 3 '17 at 22:54
  • Can anybody weigh in here? I was using Snow Leopard exclusively until a month ago. Sleep-wake and app-crash problems are new to me (knock on wood, never had issues in SL). – NewsView Jan 4 '17 at 0:32
  • 1
    Best guess would be to check for non-apple audio drivers, Boom2, Soundflower etc & remove. Try typing this in terminal too kextstat | grep -v com.apple – Tetsujin Jan 4 '17 at 7:32

You must log in to answer this question.

Browse other questions tagged .