I have a MacBook Pro (Retina, 15", Mid 2015) running El Capitan (10.11.6).

It will often run for days with no issue. I will be using the Mac at the time, then suddenly the screen shuts down black as if its gone to sleep (nothing that I've done knowingly has triggered this). There is nothing that I can do to then turn on the Mac - Power button does nothing and pressing the touchpad also does nothing. I have to close the lid and then open it again to wake it up.

When I then open up the Mac, it will stay awake and then repeat the above over and over, only staying awake for 5 - 15 seconds at a time before sleeping again.

I have run:

    pmset -g log

.. and i get (amongst all other lines)

    Entering DarkWake state due to 'Clamshell Sleep': Using AC (Charge:100%) 

From all my Googling, this seems to indicate that the lid has been shut, but the lid is still open.

Any hints on how I can stop this from happening?

ALSO: This is the 2nd MacBook Pro this has happened to, so seems to be a user profile or software thing over a hardware thing. This issue has followed me moving from one machine to another with a Time Machine backup...

3 Answers 3


I don't know if this might be pertinent to your situation, but I once had a very similar problem with a 2009 MBP. The weird thing was when I picked it up and moved it, it would wake up. This went on for weeks until I finally figured it out; it would sometimes fall asleep when I put it on top of a (closed) white MacBook. It turns out both the MB and MBP sense the lid is closed via a magnet in the lid and a magnetic sensor near the front of the machine. When I laid it on top of the MB the MB's magnet triggered the sensor in the MBP making it think the lid was closed. So, it might be worth noticing if you've got any strongish magnets in the area around the front of the machine when it spontaneously takes a nap.


My first instinct would be to reset both the NVRAM and SMC. Try the following and let us know how you go.

Reset the SMC

For your particular MacBook Pro, here’s what you do:

  1. Shut down your computer
  2. Keep the power cable plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

Reset your NVRAM

Older Macs had what's called Parameter RAM (PRAM), newer Macs use Non-Volatile Random-Access Memory (NVRAM). Either way, here’s how to reset this:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. mouse speed, time and date/timezone, etc).

  • thanks @Monomeeth - i've tried both of those. I'll let you know how it goes. Jan 3, 2017 at 6:49
  • 1
    no luck @monomeeth - worked for a few hours and just got another sleep as I was using the laptop again... Jan 3, 2017 at 9:16

I had another problem that was strangely solved by @Felix answer

My MBP 13" 2019 wouldn't wake after opening lid on Catalina / Big Sur with

Sleep wake failure in EFI 0xFFFFFFFF0000001F

I tried all suggested workarounds, e.g. sudo pmset -a standby 0

I found that the magnet from my new laptop case caused this issue as I always placed MPB on top of the case or carried MBP in it

I found it after checking pmset -g log. After failing to wake and stating that the display is off, MBP suspiciously entered sleep state again

Entering Sleep state due to 'Clamshell Sleep':TCPKeepAlive=active Using Batt (Charge:82%)

Google landed me on @Felix answer, and in the comments @Allan stated that even the smallest magnet could cause this: https://osxdaily.com/2012/05/26/stupid-but-useful-mac-trick-turn-off-internal-macbook-pro-screen-with-a-magnet/

Thanks @Felix & @Allan, you saved me from 1000$ logic board replacement :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .