I have a Macbook Air "Early 2014" with OS 10.11.6.

A few months ago, I used a lavalier mic plugged into the headphone/mic jack of this Macbook Air. I recorded lots of audio narrations of presentations that way. My lavalier mic uses the 3-striped TRRS type of male plug.

(In case it's relevant: over the past few months, I've updated the OS whenever prompted to, and I've also played with audio extensions such as Soundflower to allow recording of Skype calls.)

Now, my Macbook seems unable to use my lavalier mic. And it also fails to record audio from my iPhone headphones (which also use a 3-striped TRRS type of male plug and have a built-in mic).

I've tried to completely uninstall Soundflower and any other audio related programs / extensions.

I know that my lavalier and iPhones headphones mic still work because I've tested them with other devices today.

So there seems to be a problem either with the Macbook Air port (extremely unlikely) or with some sort of software or setting (very likely).

Without completely reformatting my drive and reinstalling OS X, how can I figure out why my mic no longer works and fix it?

P.S. When I do try to record, the tiny embedded microphone built into the left of the keyboard is what is recording (instead of my plugged-in mic). I know this based on my tapping on the external mic and tapping on the keyboard to determine the loudness of which sounds get picked up. Thanks.

P.P.S. I've already read these posts, and they are not helpful for my situation because I already know about TRRS and what kind of external mic to use and have one that has already worked:

  • 2
    The analog microphone input and/or speaker output is switched from the internal device to the external device when a plug with that capability is detected. This happens at a very low level which cannot easily be overridden. What this means for you is that since your computer is sourcing audio from the internal microphone even though your external mic is plugged in, I believe your mic must not be detected in the port for some reason. Do you have any other microphones to test your port with?
    – Tuesday
    Commented Jan 2, 2017 at 22:20
  • @timothymh When I follow "Is there a way to tell that my system can use the external microphone?" at support.apple.com/en-us/HT201919, my lavalier does not get detected, but my Bose headpones/mic do, and so do my iPhone headphones/mic. But my lavalier used to work well on this Macbook Air, and it still works well on other devices. So I'm super confused about why it recently stopped being detected as an external mic on this Macbook Air.
    – Ryan
    Commented Jan 2, 2017 at 22:22
  • 1
    @Ryan Honestly if it was working, then started working intermittently, and now has stopped working with both the lavalier and iPhone headset, it really does sound like a hardware failure. If the audio port still works as a sound output device but mics are not being detected it may be only part of it that failed, but given when you've written I'd bet on a hardware issue. Commented Jan 6, 2017 at 15:09
  • 1
    @ThomasHajcak I don't see how it could be a lavailer hardware issue given that my lavalier still does work (every single time) when connected to other devices, such as my iPhone, & I don't see how it could be a Macbook Air port hardware issue since the port works (every single time) when I am using either a Bose headset mic or EarPods mic. The only combo that sometimes fails (i.e. almost always fails) is the lavalier plugged into the Macbook Air. I'd love to try any other suggestions because I can't think of what else to try. I really don't want to replace a lavalier that still works. Thanks!
    – Ryan
    Commented Jan 6, 2017 at 23:02
  • 1
    @Ryan Even if you don't think it's the lavalier, you may want to reach out the manufacturer to see if they have a known issue with Sierra. The only other piece of troubleshooting I could provide is asking if you're using an extension cord for your audio port. You got me from my answer to another question where there's an issue connecting headsets with a mic through an extion cord that causes them to not be picked up as a mic. If that's not your case then I really have to say to contact the lavalier's manufucturer. Commented Jan 8, 2017 at 13:36

1 Answer 1


I had the exact same problem on my MBP late 2015 (running Catalina 10.15.7) with a Rode Mic and a TRRS adapter. Everything was perfectly fine and during a live transmission the mic went dead. I had to quickly switch to my AirPods (awful sound compared to a external mic) to complete the transmission.

I tried ALL possible solutions documented on the web and Apple Support pages. MBP would just not recognize it anymore on the Sound properties.

I tried SMC reset, NVRAM reset, upgrade to last patch (I was one patch behind), upgrade to Big Ser (new OS).. nothing.

I decided to reinstall and restore from Time Machine, since I didn't have interest in running Bigsur yet. Voilà!!! Worked!

It seems the reinstall + Time Machine restore fixed something that was corrupted in the OS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .