2

I have a 17" MacBook Pro. I had Mavericks installed on it and I am trying to format it in order to install a fresh copy of the OS.

Here are the things I've done and the results:

  1. I erased Macintosh HD in Recovery Mode by using Command+R in the boot stage. That worked.

  2. I pressed on Reinstall OS in the OS X Utilities window in Recovery Mode, everything went smooth until it reached the Mavericks installation process. It got stuck and I had to turn it off because it stayed at "6 minutes remaining" for like 2 hours.

  3. I read in many places that I needed to use the Internet Recovery option. So I booted using Command+Option+R. It takes me to the Wi-Fi selection and after several hours, it took me to the macOS Sierra page which failed and gave me an error (no Mavericks OS was found anymore).

  4. Then I read that it might be caused because of an unstable Internet connection. I tried my home Wi-Fi, I tried my phone's 3G hotspot, both options gave me a 3001f error.

  5. I tried a wired network and it instantly gave me 1006f error.

Step 4 and 5 were both initialized with Command+Option+R.

Right now, I am downloading macOS Sierra from the App Store from another Mac and will try to boot it from a USB in order to install it. I am not sure if that will work. Let me know if it is a waste of time or it will work!

2

How to make a bootable usb with the Sierra installer from the App Store. Change "MyVolume" to the name of your usb drive

sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ macOS\ Sierra.app
  • I am trying to boot from the usb by using the Option key. But the screen is white when the mac is turned on and nothing happens. – unfinishedwindow Jan 1 '17 at 18:02
  • I managed to get Sierra installed. After the installation was done, the screen went blank. So I turned the computer off and now when I turn it on, it gives me a white screen, I can't even enter recovery mode. Help please! – unfinishedwindow Jan 1 '17 at 23:47
  • You'd need to open a new question to deal with that. – Tetsujin Jan 2 '17 at 10:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .