It's not a new problem, I'm facing it for sometime now. My MacBook runs fine all the time but this kernel_task issue occurs whenever it awakes from sleep. No issues with DisplaySleep. I can't put the lid down and have to restart every time. I have googled a lot and tried the following:

reset smc/nvram/pram multiple times, ACPI_SMC_PlatformPlugin.kext Solution, also left the macbook running for whole day and rebuild the spotlight index.

I've gone through the following two links on this forum: debug kernel_task process and investigate high kernel_task memory

Output of above mentioned command follows:

  • kextstat | grep -v com.apple

     Index Refs   Address               Size       Wired      Name (Version) <Linked Against>
      110    0    0xffffff7f80b77000   0x5000     0x5000     com.Cycling74.driver.Soundflower (1.6.6) <109 5 4 3>
  • kextstat -l -k | awk '{n = sprintf("%d", $4); print n, $6}' | sort -n

    kexstat_result at pastebin


Ran syscallbypid.d while facing the kernel_task problem and again ran sudo syscallbypid.d while system was normal. After comparing the output of these two commands, I found the following process were unique to kernel_task problem and were not shown in the normal run.

AirPlayUIAgent, WorkflowService, locationd, networkd, diskarbitration, SleepServicesD, EscrowSecurityA, mdworker & launchd sysctl.

Any one of these might be causing the problem. Another difference I noted was com.apple.iclou process was running in normal run and not in the problematic one.

Can this problem be narrowed down further ? Any light on how to overcome the CPU throttling will be of immense help.

  • Does the same thing happen when you put the Mac to sleep before you close & reopen the lid?
    – IconDaemon
    Jan 1, 2017 at 17:47
  • 1
    It isn't a solution but since lid-sleep is the main cause for spike in cpu usage for kernel_task, I've disabled it through insomniaX and the trouble is avoided for now. Normal sleep & lid down is not a problem.
    – lawsome
    Jan 3, 2017 at 7:20
  • hi @icondaemon, I've made an edit to the original question. Can you see if the edit helps.
    – lawsome
    Jan 5, 2017 at 20:14
  • What are you using Soundflower for, in particular? Is it essential for what you do? Have you installed the latest version to make sure it's not a compatibility issue? Does the problem disappear when you uninstall Soundflower? Questions, questions, questions!
    – IconDaemon
    Jan 5, 2017 at 23:12
  • @icondaemon, soundflower is not relevant at all, removed it completely & checked, the problem still persists. However in an another approach. I turned wi-fi off, removed everything from login items, disabled other login items individually. Then put my system into sleep four times, every time after a restart, for 20 sec, 35 sec, 50 sec & 90 seconds respectively. Only for 20 and 35 seconds the problem doesn't occur. I took out the console logs for these four occasions. Here is the filtered [result] (pastebin.com/L3YkF1mK) from my console. This was my last try. 'll reinstall OS afterwards
    – lawsome
    Jan 6, 2017 at 10:15


You must log in to answer this question.

Browse other questions tagged .