0

It's the weirdest thing! It used to work perfectly. My TV at home does not have HDMI, but the VGA input works great. When I ordered this new MBP, I got all adapters from Apple. Today is when things got weird:

When I plug in thunderbolt 3 -> VGA I get nothing.

When I plug in thunderbolt 3 -> thunderbolt 2 -> VGA I get nothing.

HOWEVER, if I plug in the single TB3 -> VGA - ONLY directly after trying the above two adapters - it works. I'm saying the first adapter I tried works one single time, but only after trying to plug the same thing in using the second two adapters.

What the heck could this be?

5
  • Bizarre. Your question is a little ambiguous: did this problem start with your new computer, or was it working fine some time after you got it?
    – Tuesday
    Dec 31 '16 at 3:16
  • I apologize. It worked perfectly at first, and yesterday it started the above stuff. Dec 31 '16 at 14:31
  • I spoke to Apple and they determined that it's software, and that I have to completely format + reinstall to fix it! Dec 31 '16 at 14:32
  • Okay, I have verified the following: Jan 1 '17 at 6:39
  • Okay I have verified: 1) The problem exists in the exact same way on a 100% clean install, no data transferred. 2) The tv VGA input works, since it fires up every time with the 2012 MBP. 3) All the adapter cables work Therefore it must be a bug in the OS? Not fixable? The workaround does work consistently, it’s just a hassle and puts tons of necessary wear on the connectors! I hope those TB3 connectors hold out. Jan 1 '17 at 6:44
1

It's a bug. If I leave the USB-C adapter plugged in, the VGA can be connected and disconnected without issue. That's the only way, other than my weird multi-adapter method. Kinda sucks to have to leave the adapter in, but that is the only way. I actually got a whole new MBP just for this issue, and the new one acted exactly the same BEFORE I imported any files or settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .