1

I have an external 2TGB HD which I use as a TimeMachine backup. This is permanently connected to my MacBook Pro whenever it is on my desk and connected to power.

I noticed that no backups had been performed for 3 days, and after some investigation discovered that it had developed a problem.

Disk Utility will not run when the drive is connected (it displays "Loading disks" until I give up).

diskutil list /dev/disk3 shows:-

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *2.0 TB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Time Machine Backups    2.0 TB     disk3s2

diskutil info /dev/disk3s2 shows:-

Device Identifier:        disk3s2
Device Node:              /dev/disk3s2
Whole:                    No
Part of Whole:            disk3

Volume Name:              Time Machine Backups
Mounted:                  Yes
Mount Point:              /Volumes/Time Machine Backups

Partition Type:           Apple_HFS
File System Personality:  Case-sensitive Journaled HFS+
Type (Bundle):            hfs
Name (User Visible):      Mac OS Extended (Case-sensitive, Journaled)
Journal:                  Journal size 155648 KB at offset 0x3a38000
Owners:                   Enabled

OS Can Be Installed:      Yes
Media Type:               Generic
Protocol:                 USB
SMART Status:             Not Supported
Volume UUID:              042E821E-5296-3ABD-84EB-2D079D0FB7CE
Disk / Partition UUID:    BB3F7234-80E7-48BA-A241-C09C82A6117E

Disk Size:                2.0 TB (2000054960128 Bytes) (exactly 3906357344 512-Byte-Units)
Device Block Size:        512 Bytes

Volume Total Space:       2.0 TB (2000054960128 Bytes) (exactly 3906357344 512-Byte-Units)
Volume Used Space:        1.9 TB (1873327808512 Bytes) (exactly 3658843376 512-Byte-Units) (93.7%)
Volume Available Space:   126.7 GB (126727151616 Bytes) (exactly 247513968 512-Byte-Units) (6.3%)
Allocation Block Size:    4096 Bytes

Read-Only Media:          No
Read-Only Volume:         No

Device Location:          External
Removable Media:          Fixed

diskutil repairDisk /dev/disk3 shows The partition map appears to be OK

I have tried various repair/verify steps; diskutil repairVolume /dev/disk3s2 shows:-

Started file system repair on disk3s2 TimeMachine2
Repairing file system
File system check exit code is 8
Updating boot support partitions for the volume as required
Error: -69845: File system verify or repair failed
Underlying error: 8: Exec format error

Can anyone suggest how I could repair the partition?

Failing that how would I go about copying the TimeMachine backups from a similar disk, which I use as weekly backups?


I was using the Mac and left Disk Utility running; after some hours I noticed the TimeMachine Volume was mounted, so I ran First Aid with the following result:-

Repairing file system.
Checking Journaled HFS Plus volume.
Checking extents overflow file.
Checking catalog file.
Checking multi-linked files.
Checking catalog hierarchy.
Checking extended attributes file.
Checking multi-linked directories.
Checking volume bitmap.
Checking volume information.
The volume TimeMachine2 appears to be OK.
File system check exit code is 0.
Updating boot support partitions for the volume as required.
Operation successful.

I was able to perform a backup.

I noticed the drive had directory containing DamagedFiles which appeared to have been created by my earlier repair attempt, with the following content.

lrw-rw-rw-  1 root  wheel  74 30 Dec 16:44 004223b3 permStore -> ../.Spotlight-V100/Store-V2/577031D1-2841-49E4-AEF2-F1BE828ECEE6/permStore
lrw-rw-rw-  1 root  wheel  56 30 Dec 16:44 00e9bbf9 .Backup.log -> ../Backups.backupdb/Zaphod/2016-12-27-214522/.Backup.log
lrw-rw-rw-  1 root  wheel  62 30 Dec 16:44 00e9bbfb .exclusions.plist -> ../Backups.backupdb/Zaphod/2016-12-27-214522/.exclusions.plist
lrw-rw-rw-  1 root  wheel  82 30 Dec 16:44 00e9e046 User Guides And Information -> ../Backups.backupdb/Zaphod/2016-12-27-214522/Fenchurch/User Guides And Information
lrw-rw-rw-  1 root  wheel  60 30 Dec 16:44 00e9e047 Users -> ../Backups.backupdb/Zaphod/2016-12-27-214522/Fenchurch/Users
lrw-rw-rw-  1 root  wheel  58 30 Dec 16:44 00e9e048 usr -> ../Backups.backupdb/Zaphod/2016-12-27-214522/Fenchurch/usr
lrw-rw-rw-  1 root  wheel  58 30 Dec 16:44 00e9e049 var -> ../Backups.backupdb/Zaphod/2016-12-27-214522/Fenchurch/var
lrw-rw-rw-  1 root  wheel  62 30 Dec 16:44 00e9e04a Volumes -> ../Backups.backupdb/Zaphod/2016-12-27-214522/Fenchurch/Volumes

I would still like an explanation for the reason for the hours delay in mounting, and my other questions.

  • It seems strange that diskutil would not find any error with the drive, perhaps run Time Machine's own verify backup function? You can do this by option-pressing the TM icon in your menubar and selecting "verify backups". I would reason it's due to the sparse bundle having issues instead of your hard disk. – perhapsmaybeharry Jan 1 '17 at 6:52
  • @perhapsmaybeharry diskutil did find error "Error: -69845: File system verify or repair failed" initially (I tried a couple of times). I was unaware of "verify backups", but it appears to be greyed out on my system. – Milliways Jan 1 '17 at 9:01

You must log in to answer this question.

Browse other questions tagged .