This should be so straightforward but it's not working for me. I've followed Agile Bit's help guide for setting up a new Mac but it's not working.

I have 1Password installed on one machine. It's completely populated with passwords and a master password on the agile keychain as been set. The keychain is stored in ~/Dropbox. The Dropbox sync occurred and I can see the same keychain file on my other Mac. MD5 checksums match on the files.

When I go to setup 1Password on the new Mac I have two choices when I first run it:

  1. I am a new user
  2. I have already used 1Password

If I take choice 2 I get a file finder window. I navigate to ~/Dropbox and select my agile keychain file. 1Password flashes a loading dialog window and then...nothing. It doesn't show me the Master Login window. Command 0 doesn't bring up the window. I can go to 1Password -> Unlock... and it will give me a small dialog window asking for the Master Password, but the password I used for that agile keychain gets rejected. I just keep getting recycled back to enter password dialog box.

If I take choice 1 I get the option to find information from a previous install. Again, I navigated to that agile keychain in ~/Dropbox. Again, 1Password does some quick loading and then...nothing. Same story as above.

Both of those actions above could conform to what the Agile Bit's documentation says for setting up a new machine and using an existing, sync'ed agile keychain. Neither of them work.

I hesitate to fill out a new profile on the new machine because I don't want to over write my existing agile keychain file and all the passwords in it.

How exactly am I supposed to setup this second machine with the shared agile keychain?

  • 1
    Have you asked this question in the Agile forums? They are generally pretty quick at responding to questions. And in your case, it seems to be that something is definitely amiss. Oct 4, 2011 at 18:51
  • Yes, I've asked on their support forum. No response yet.
    – Ian C.
    Oct 4, 2011 at 19:46

3 Answers 3


I had this exact problem over and over, with some help from Agile I found the answer here: http://help.agile.ws/1Password3/configure_dropbox_on_mac.html

Here is the important part:

To configure 1Password on your other Macs, first setup Dropbox, then make sure you have the latest version of 1Password installed and running.

Locate your 1Password.agilekeychain file in your Dropbox folder. If it has a green check mark badge indicating that the sync is complete, double click it,

and 1Password will confirm that you want to use this new location. Important If it shows the blue syncing badge rather than the green check mark badge, wait until the badge is a green check mark before opening the file. Failure to do so could result in data corruption.

  • Before you double clicked on the agile keychain did you do anything to initialize or otherwise setup 1Password on the machine? Or was it just freshly downloaded from the App Store and never run on the box before?
    – Ian C.
    Oct 4, 2011 at 19:12
  • I just tried double-clicking on the agile keychain file. 1Password asked if I would like to use it. I said yes. And then it showed me that same Welcome to 1Password screen with the two options I mentioned in the OP.
    – Ian C.
    Oct 4, 2011 at 19:15

I have experienced similar behavior in the past whenever I am running different versions of 1Password on different devices. The 1Password team at AgileBits is very fast at producing multiple updates to their product (which is great!), but they will sometimes update the software in a way that the AgileKeychain file will be only accessible by the latest version of 1Password.

In other words, make sure that you are running the latest version of 1Password in all of your Macs and/or iOS devices and try again. You seem to be following the instructions the correct way. Hope this helps.

  • I'm definitely running the same version on both machines. Installed via the App Store at about the same time.
    – Ian C.
    Oct 4, 2011 at 19:12

Did a little Console diving and figured it out.

So the right approach is to take the second option (I'm already a user) and select the .agilekeypass file in your Dropbox. But in my case this was failing because 1Password was unable to start the 1Password Helper application. There were error messages about this in the Console, but unfortunately no user-visible feedback about the problem was given by the 1Password application on the desktop.

I ran a repair of permissions on my disk and that sorted everything out. I was able to setup 1Password on the second machine, pointing it at the Dropbox-based .agilekeychain file so everything stays in sync.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .