6

I would like to enable Google's Location History on my iPhone so I can see my location history at https://www.google.com/maps/timeline.

I tried enabling this functionality as follows: Open the Google app > Menu > My Account > Personal Info & Privacy > Activity Controls > Location History. Here my iPhone is listed, with a disabled checkbox. A message is displayed that says "Use a location enabled Google app on the iOS device to change the setting". When I click on the checkbox to enable it, nothing happens.

I have Settings > Privacy > Location Services enabled, and Settings > Privacy > Location Services > Google Maps set to "Always".

Is there any way to enable the Location History functionality?

5
  • Do you have Background App Refresh turned on for Google? See this Google help page and be sure to follow all directions.
    – fsb
    Dec 29, 2016 at 20:23
  • Are you using a personal Google account, or one provided to you through work or school?
    – Tuesday
    Dec 29, 2016 at 23:36
  • Backgtound App Refresh is enabled, both in general and for Google. Dec 29, 2016 at 23:42
  • I'm using a personal Google account, however one registered through Google Apps on a personal domain that I own. Dec 29, 2016 at 23:46
  • Nobody any idea? Jan 3, 2017 at 21:27

5 Answers 5

1

I found the answer myself. For some reason, enabling the device through the Google app did not work, however the same screen in Google Maps works fine.

Open the Google Maps app > Menu > Settings > Location history > Enable the device.

2
  • Doesn't work for me on iPhone X, iOS 13. Checkbox disabled with Use a location enabled Google app on the iOS device to change the setting form both the Google and Google Maps app (they open the browser to access the setting). Location is always enabled for both apps. Any other ideas? Aug 17, 2019 at 15:18
  • The answer that worked for me is apple.stackexchange.com/a/394701/389281 Sep 15, 2020 at 13:56
1

Install and set up Trusted Contacts

This is a hot question and a top Google search result, but the the other answers here are a little outdated. There is a workaround to get location history working, and all it takes is to install and set up Google's "Trusted Contacts" app (you can uninstall it right after).

Despite Google's message: "use a location enabled Google app on the iOS device to change the setting", I have found no logical way to enable Location History in any other Google app.

Yes. It is absolutely ludicrous that this is what you have to do to enable Search History on an iPhone (you would think that Google would make it easier to voluntarily give them your data). But I'm not putting Google down. They make a lot of amazing products. This must just be a small glitch that they'll fix in the future.

Luckily it can be fixed in 2 easy steps:

1. Make sure "Location Services" is on

Make sure you have Google Maps installed, next: as per Google Maps Support, make sure that Location Services is on.

  1. Go to the Settings app.

  2. Go to Privacy.

  3. Make sure the Location Services toggle is on.

    enter image description here

  4. Then, still in Location Services, look for Google Maps and make sure "Always" is selected.

    enter image description here

2. Install and set up Trusted Contacts

  1. Install Trusted Contacts from Google LLC in the App Store.

  2. Open the app and follow all the setup instructions.

  3. When you get to the "Share your location?" screen, tap "TURN ON". This is the most important step.

    enter image description here

  4. Finish setting up the app.

!!!In Trusted Contacts make sure you agree to allow notifications when you are prompted or it will not work!!!

You're done!

Now Location History will be enabled on your iPhone! Verify by going to Location History in your Google Account settings, opening the "Devices on this account" drop-down list and making sure your iPhone has a check next to it. enter image description here

Optionally, you can now uninstall Trusted Contacts.

Important: turning off location services or going into low-power mode will most likely (now and in the foreseeable future) stop Google from saving your location history. Keep location services on and do not go into low-power mode if you want your location history to be saved.

3
  • This should be the accepted answer. It worked IMMEDIATELY. Thank you! Sep 15, 2020 at 13:55
  • @AdamAlexander Glad it worked for you! I agree, it should be xD... but unfortunately Google has shut down Trusted Contacts... not sure how to do it now... Oct 21, 2020 at 11:17
  • Trusted Contacts - this app is currently not available in your country or region. [UK]
    – Tetsujin
    Sep 7, 2021 at 16:19
0

The self-answer does not work for me. The way to get this working at present is:

  1. Download the Google App. Open.
  2. Go to Setting > Privacy and Security > Location. Ensure Location is set to "Always"
  3. Continue to ... > Location History.
  4. Ensure Location History toggled on. Finally:
  5. Expand "Devices on this account" and check mark "iPhone (this device)"

Here's a screenshot of the last screen with it all done correctly: Screenshot

2
  • Not working for me. There is no Location History menu item.
    – Rade_303
    Feb 13, 2020 at 22:32
  • Within Location History, I only see a toggle option for "Allow location services in incognito mode". Does anybody know if this solution is still current, or if I am being A/B tested? Nov 13, 2020 at 13:37
0

Seems this may be different in different territories. Though the sheet reached at the end of this journey is the same one mentioned by feetwet 2 years ago, the route to it is different.

I used to have this on all the time, but it switched itself off at the end of 2019 & I've only just figured out how to re-anable it.

This is for UK, iOS 14

Open Google Maps - tap top right of the 'search' - mine shows my Google face image, meaning I'm already signed in.
Then tap 'Your Profile'
Then tap the 'three dots' . . . menu top right, & select Profile Settings.
Click Location History [this changes wording whether it's already on or off.
This will pop another separate sheet allowing you to, at last, switch it on.

enter image description here

I have to say, that was the most tortuous app pref I've ever had to find :\

0

Solution

Fully reset iPhone using DFU mode, and setup as a new iPhone. Do not restore from a iCloud/iTunes backup.

More background

I had the same issue and was able to fix it as of 2022/9. Some of the old answers here are no longer relevant, e.g. Trusted Contacts.

My Maps Timeline was working until I upgraded to a new iPhone around 2021/12. I suspect it's because I restored from a backup and some local data got out of sync from google server, so I reset the phone using DFU mode and reinstalled everything from scratch. It worked immediately. It's a painful process, but Timeline feature is important enough for me to go through it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .