4

I have a file on my system named "2011.09.08įU0.G80.Šsl" that I'm unable to delete. Here are the different steps I've tried, but haven't had any success with yet:

  • sudo rm file - Results in "No such file or directory"
  • Deleting via Finder - "The operation can't be completed because one or more required items can't be found. (Error code -43)
  • Renaming via Finder - "An unexpected error occurred (error code -43)
  • sudo mv file newName - "No such file or directory"
  • Deleting using the "Locked" files feature in Cocktail - "An invalid character has been found in the path."
  • Sharing the folder in question with read+write access, logging in via Windows 7 and attempting to delete, but Windows is unable to even see the file in question.
  • Deleting/renaming the parent folder of the file via Terminal fails - "Directory not empty"

I've also tried the steps described in this question, but haven't add any success there either.

The primary reason for trying to delete this is because whenever my backup solution (SuperDuper!) encounters this file, it aborts the backup, leaving me flying without a net. Any help would be greatly appreciated.

  • Perhaps you could delete the folder containing this undeletable artifact with an rm -rf? That would get past the "directory not empty problem" for the parent dir. – JW8 Oct 4 '11 at 16:20
  • 1
    Thanks for the suggestions folks. I've tried the suggestions from Mark and CanuckSkier below, but with similar results as from above. It's looking like this file may be part of a larger problem. After using Disk Utility to verify the disk, it said the disk was in need of repair. After booting from an OS X install disc, Disk Utility was unable to repair the disk, and told me that reformatting needed to be done. So… I'm currently in the process of backing up as much as possible before beginning the reformat/reinstall process. Bummer. – Josh Buhler Oct 4 '11 at 16:56
  • → Josh: Be cautious to use a Disk Utility on external disk of the same MacOS X version as the one which is on your disk. Otherwise your Disk Utility might be creating inconsistencies within your file system. – dan Oct 18 '13 at 22:10

10 Answers 10

2

Try deleting interactively to avoid deleting too much since these characters match one or many/no characters - you can answer y or n as needed as each file comes up for deletion...

e.g.

sudo rm -i 2011.09.0?*

If you can't get the wildcard right, move everything else out of the folder in question, go one directory level up and rm -r <foldername>.

  • No luck. Still getting the same errors as above. – Josh Buhler Oct 4 '11 at 16:53
1

sudo rm 2011.09.08<tab> will invoke auto-completion which should escape or otherwise resolve the odd characters for you. Make sure it's the only file that begins in 2011.09.08 though.

0

I'm guessing that it's balking at the file name. Are you using quotes when trying to remove it in via the terminal?

Maybe try using wildcards instead of the full name. I.e. rm 2011.09.08*. That would of course delete any other files in that directory starting with 2011.09.08, so you should move them first. you could also try rm *U0.G80* which might require shuffling fewer files around.

0

Move it to the trash and go to the Finder menu and select "secure empty trash."

0

The comment about repairs to the file system is consistent with the (historical) definition of file system error code -43

fnfErr

File not found; Folder not found; Edition container not found; Target not found

Mac OS System Error Codes: 0 to -261

0

Trash It! is an AppleScript-based application that force-empties your Trash and/or removes stubborn items. Especially useful if you have files or folders in the Trash with permissions set incorrectly, locked Trash items, want to securely delete a stuck item, or trash items from other partitions. If you drop files or folders onto the Trash It! icon, it will delete them as well. If you double-click on it, it will clean out your Trash can.

0

Today I faced this issue on my iMac with OSX 10.11.2

What I did is 'Relaunch' Finder.

Step 1: Click on Apple icon on top menu and click on Force Quit

enter image description here

Step 2: Select finder and click on Relaunch enter image description here

0
  1. ForceQuit All App
  2. Empty Trash
  3. Relaunch Finder

This fix this issue...

0

If you can move the stubborn file, remove using "root user" access with sudo -i rm -R <foldernamehere>

Create a new folder on the root of you main HDD

  1. open your main hard drive...
  2. double-click the main HDD icon, or... 2a. menubar > File > Go > "Go to folder" (cmd+shift+g) 2b. type "/" and press return
  3. menubar > File > New Folder (cmd+shift+n)
  4. enter your admin user name and password
  5. name the folder "deleteme"

Move your stubborn file to the new folder "deleteme"

  1. drag and drop the file (myfilename) into "deleteme"

Remove the directory using "root user" access

  1. open terminal.app --> it shows "mymacname:~/ username$ "
  2. change to the root of your main HDD, "cd /"
  3. you should now see "mymacname:/ username$ "
  4. type sudo -i rm -R /myfilename and press return
  5. enter your admin user name and password

The containing folder (deleteme) and stubborn file that you put inside the folder should be gone for good.

0

I have solved a similar simulation using linux (ubuntu in my case)

sudo apt-get install hfsprogs sudo umount /media/myMountPoint (in case it is mounted) sudo fsck.hfsplus /dev/sdXY sudo mount -t hfsplus -o force,rw /dev/xxxx /media/myMountPoint

and then remove it using rm with wildcards. Use a live cd to boot into linux e.g.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .