0

I have a CD which I'm trying to add to iTunes, however my MacBook Pro won't read it. Every time I put it in it tries to read it, clicks and ejects after approx 20 secs. I've played the CD in a CD player with no problem so I don't think the CD is the issue and I can read other CDs no issue.

Things I've tried so far:

  • Reset the NVRAM
  • Reset the SMC
  • Renamed the cdinfo.cdlib in the preferences directory.
  • Run a cleaning CD through.

I tried the above separately with a test of the CD between each.

Any thoughts?!

  • 2
    Did you try the CD in a different computer? – nohillside Dec 29 '16 at 16:17
  • Is this a CD you created yourself or an original, store-bought purchase? – fsb Dec 29 '16 at 16:24
  • It's a store bought CD. Not had the opportunity to try it in a different computer yet. – jaz9090 Dec 29 '16 at 16:29
  • Tried it on a PC and it imported fine. – jaz9090 Dec 30 '16 at 10:21
1

it is possible that the CD has a scratch on it or is dirty. When this happens to me I wash it in the sink.

Warm water, and put a little dish soap on your hand (remove any rings!) and gently rub the CD back and forth (never round and round) until all the soap is gone. Dry with a soft towel (not paper towels) and try the CD again.

You could also examine the surface for scratches. If you find any, you could try the toothpaste method for buffing out the scratch (google it for details).

Failing that you may have to find a friend who can rip it for you. Some optical drives just have a problem with some CDs and DVDs. Sometimes I have to use another Mac or even an old PC to rip recalcitrant optical media.

  • It's a new CD and looks perfect so I don't think a wash/buff would help. – jaz9090 Dec 30 '16 at 10:21
  • ...well it only takes a minute, and you would be surprised. Then you can try another computer or take the CD back to the store and have them replace it. – Steve Chambers Dec 30 '16 at 13:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .