My new macbook laptop keeps losing the sound, anyone knows anything I can do besides restarting or logging out?

Last time It fixed itself automagically, it's a macbook pro 2016, 13" with touchbar

I can even hear a tick when I switch from hdmi to the headphones but it wont output any sound from youtube or VLC or anything else.

I can only hear Siri.

I can't afford to be restarting my computer manually every time this happens.

On linux I can restart the service and fix it but I don't know how to do it in mac.

OS Version: macOs Sierra 10.12.2

  • I'm having the same problem on a 2016 15" MacbookPro. Only your "sudo killall coreaudiod" (or restarting) sorted it out. Are you using by chance any wireless/bluetooth earphones from time to time? I'm trying to reproduce the bug, and it usually happens after listening to music/videos with my AirPods. Submitted a bug though to Apple, just in case). By the way, did you experienced it outside Mac OS (Linux/Windows)? Could it be hardware related?
    – eiprol
    Jan 22, 2017 at 16:09

7 Answers 7


Fixed it with sudo killall coreaudiod

  • This "worked", as in I can hear sound again, but now the volume control doesn't work. Mar 21, 2017 at 13:19
  • It looks like coreaudiod doesn't restart itself (unless you shut/reopen the laptop lid). Perhaps we could manually restart coreaudio daemon via launchctl?
    – Demis
    Aug 22, 2017 at 13:04

If your Control Strip stops working after sudo killall coreaudiod try sudo killall ControlStrip afterwards.

  • 1
    killall coreaudiod && killall ControlStrip ftw
    – Simon
    Apr 6, 2017 at 5:28
  • 1
    killall coreaudiod && killall ControlStrip and closing and opening the lid fixed it for me, included working volume control. Aug 22, 2017 at 23:07

I experienced this problem with a MBP 13" TB, which I use with AirPods. Probably the combination of using Airpods/a bluetooth audio device is what's causing this problem.

What worked for me was:

  1. sudo killall coreaudiod
  2. sudo killall ControlStrip
  3. Open/Close laptop lid
  • This made the volume control work again - presumably by restarting CoreAudioD somehow. Perhaps we could manually restart coreaudiod via launchctl?
    – Demis
    Aug 22, 2017 at 13:04

I don't have enough reputation to leave a comment, but in response to evolutionxbox's comment:

After running sudo killall coreaudiod in the Terminal, I made the volume controls work again by putting the machine to sleep and then waking it back up.


I called Apple Care and they took care of this problem. I shut down the computer first and immediately as I turned it back on, I pressed down optioncommand on the left side and the R and P keys simultaneously for 20 secs as I was told to do.

The audio problem and display flickering both went away. Apple Care did this with me just via phone and took less than 5 min!

  • Just so everyone knows, the process you followed is called resetting the NVRAM, and the steps you took are only for (at this stage) the new 2016 MacBook Pro computers. Anyone looking to resolve a similar issue with any other Mac can refer to my answer here.
    – Monomeeth
    Mar 9, 2017 at 21:08
  • I have also called Apple Care. They also helped me do SMC reset and NVRAM reset. But it does not work. I am using a 2017 MacBook Pro with touchbar. Oct 3, 2017 at 6:02

When I was debugging a component using AVPlayer playing a video and the debugger stopped the execution, the sound manager seemed to be stopped also and there was no sound.


This is a very annoying problem. Just fixed it by switching the power cord from the front right USB port to the back right USB port. Very strange and aggravating! Otherwise used the sudo command noted above with success.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .