My MacBook Pro (2010) doesn't want to charge when I plug my MagSafe into it. This is what I get:

MagSafe doesn't light up

I already looked at Apple's support page, but it still doesn't work at all. How can I make my computer charge again?

  • 1
    Try moving it to Bordeaux. Seriously though, I think this indicates a dead battery. – mustaccio Dec 29 '16 at 2:59
  • My battery is actually not "dead" I mean, it still work (not now, because I can't charge it). @mustaccio – Arthur Guiot Dec 29 '16 at 3:02
  • Well, that's hard to prove, isn't it? If, after you connect the charger, its light briefly goes on and then off, it's likely that your battery is dead; if it never goes on, it's likely the charger is dead. Borrow a known good charger and try. – mustaccio Dec 29 '16 at 3:06
  • Ok, do you think that if I bring my charger and my Mac to an Apple Store, I'll be able to test if it's my battery or the charger? I think it's the charger, because the light doesn't goes on @mustaccio – Arthur Guiot Dec 29 '16 at 3:08
  • The only thing I can be sure about regarding the Apple Store is that they will certainly sell you something. – mustaccio Dec 29 '16 at 3:10

I know there's a question mark over your charger, so it's understandable you may not have tried this, but it's still worth at least trying an SMC reset.

To do this on your MBP, follow these steps:

  1. Shut down your computer
  2. Keep the MagSafe adapter (or power cable) plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

If nothing happens, you could use the MagSafe lead and connect it to one of the newer MagSafe 2 adapters you have (keeping the lead but changing the power source) and then trying the SMC reset again.

Let us know how you go.


Ok, your MBP 2010 has a 60W Power Adapter and so does the MBP 2013.

If you can borrow that (the MBP 2013 adapter), then connect your MagSafe lead to that and connect it to your MBP 2010 for a while and leave it. Take note of whether the power/charge light comes on or not.

Regardless, leave it connected for at least a half hour and then try starting your computer. If it boots okay, then check the battery status (in the menu bar) to see how much charge it has and whether there's any sort of error message. If there is, take a note of the message. Then shut down your computer and leave it connected to power for a while (if possible, long enough for what a usual charge would take).

Finally, before having to return the adapter, redo my steps for resetting the SMC.

Once you've done all this, report back on how this all went (any power light, any charge, any error message, etc).

  • Well, nothing happenedto the charger – Arthur Guiot Dec 29 '16 at 7:26
  • And my computer doesn't have battery anymore after your manipulation... #poorcomputer – Arthur Guiot Dec 29 '16 at 7:27
  • What do you mean by my computer doesn't have battery anymore after your manipulation? I thought that was the whole point of your question - no battery? And are you saying that using your MBP 2010 MagSafe lead with one of the other adapters results in no light appearing at all when you plug the lead into the computer, not even for a split second? Also, can you specify what other Macs you have access to? – Monomeeth Dec 29 '16 at 7:35
  • Ok, sorry you didn't understand me, before you post this answer, my mac was at 3% of battery and when I did your manipulation, it started normally and, about 10 seconds after the computer finished to boot, it directly shut down. I have access to an iMac, a MacBook Pro 2013, a MacBook 2015, and a MacBook Air 2014 but these are not mines, I only can access to them for a short period of time if I ask my friends (hope you'll understand my complicated situation) – Arthur Guiot Dec 29 '16 at 7:42
  • What inch screen does your MBP 2010 have? And what size screens do the MBP 2013, MB 2015 and MBA 2014 have? – Monomeeth Dec 29 '16 at 7:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .