18

I am trying to add a gmail account to my iPad in order to have contacts, email, and calendar sync. I go to Settings -> Mail -> Accounts -> Add Account and enter my gmail credentials. It accepts the credentials and then goes to this screen: post authentication screen

The spinner to the left of Gmail will spin for about 20 seconds then it just takes me back to this screen: add account screen

The account never gets added. I get an email on my phone that says "new sign in from iPad" so I know the authentication is working.

I am using iOS 10.2.

The same problem existed in 10.0.2.

Some users have reported that doing this process over 4g rather than WiFi works, but this is a WiFi only device.

The gmail app is installed and logs me in just fine.

The same thing happens on both my 2 factor authentication account and my account without 2FA.

  • 7
    Even i also was facing the same issue. The reason for me was that i was using my outlook ID to signin to Google. I had everything on Google except a gmail ID. So when i sign in, iOS was trying to access the Gmail account also, but it coudn't. It goes back to the account adding page. The solution i found was logging in and going to Gmail where it always promted to create a gmail address. I created a gmail address and now i have Gmail in my Google account, i tried logging in again and it worked on my iPhone running iOS 10.3. – Ajith Memana Oct 18 '17 at 3:37
  • On Monday 2nd April one of my iPhone GMail accounts (my main one helpfully!) showed 'Cannot get Mail, the mail server "imap.gmail.com" is not responding...'. I had changed nothing. I read a bit, deleted the account, then tried to re-add. Then suffered the same problem above. Looking on my iMac it was not showing a problem but not refreshing. By 15:30 on Monday the connection was working. I have other GMail accounts which work. I am unsure of where to go now! – Luke West Apr 4 '18 at 11:45
  • The wifi switch off does not work. Geofencing this is strange. I have bought storage but that appears to be fine. As a result I am rather purplexed – Luke West Apr 4 '18 at 11:57
  • 2
    @AjithMemana Had the same problem. It was not working because I did not have a gmail address assigned to my google account. – cansik Nov 6 '18 at 8:51
  • @AjithMemana I think your suggestion deserves to be an answer too :) – WhatHiFi Dec 18 '18 at 10:00
9

I had this problem too.

When I checked on google if there was a security issue (https://myaccount.google.com/device-activity) I noticed that my iphone location was overseas.

I then realised that iPhone was connected to my company wifi and was routed via their overseas hub.

So I disabled the wifi so that only the local mobile data was being used.

After that the add mail > google then worked.

  • I had to use the company wifi instead of 4G – Aerylia Jun 1 '18 at 9:43
  • 3
    Wifi or 4g data connection. nothing works for me. – NSNull Jun 4 '18 at 5:02
  • @NSNull I turned off WiFi and also quit out of both the Mail and Settings apps. Not sure if quitting and re-launching was necessary, but if disabling WiFi alone doesn't work, that's one more thing to try. It worked for me. – Mentalist Jun 30 '18 at 11:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .