0

It seems that Chrome causes a crash on macOS whenever I insert a USB Ethernet adapter.

For a long time I didn't know the reason; I just plugged it in and tried it again and again until my Mac accepted it and let me use it. I thought it was just a problem with macOS.

But yesterday, I changed the default browser to Safari, and I was able to successfully use my adapter the whole day. At the end of the day I decided to make Chrome my default browser again, and my Mac crashed.

Today I experimented more and found that whenever I connect to the Internet via Ethernet, everything is OK until I open Chrome. I tried disabling all my plugins but it didn't help.

What can I do?

  • I edited your question for clarity; could you read it over and see if I misunderstood anything? Also, when you say you tried disabling your "plugins", do you mean your Chrome extensions? – Timothy Mueller-Harder Dec 28 '16 at 20:18
  • Further information that would be helpful: What brand of adapter are you using, and what version of macOS and Chrome are you running? Does Chrome work with other network interfaces, such as Wi-Fi or tethered to your phone? If you could edit your question to include all this information, that would help a lot towards diagnosing your problem. – Timothy Mueller-Harder Dec 28 '16 at 20:19
  • macOS Sierra 10.12.2 (16C67), USB 3.0 to 10/100/1000 Gigabit RJ45 Ethernet LAN Network Adapter 1000Mbps Chrome works perfectly with wifi and bluetooth tethering, the only problem is with this usb2lan cable, – Aziz Jan 12 '17 at 0:11
0

It's the realtek drivers which cause the hang which the USB ethernet adaptor tries to use and Chrome seems to get mangled into it. If you're running the latest Sierra you probably don't actually need these installed. You can either remove them both through /library/extensions RTL815 or run the scripted uninstaller that comes with the package from http://www.realtek.com.tw/Downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=55&Level=5&Conn=4&DownTypeID=3&GetDown=false

  • Thank you. I removed the drivers, and now it doesnt crash – Aziz Jan 16 '17 at 7:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .