Presumably since the last update to macOS 10.2.2, the system started to switch to my Bluetooth headphones automatically every time they come in Bluetooth range. That means that my Macbook switches audio output every time I come home (I use them on my iPhone as well). Even if I explicitly set the audio output to "Internal Speakers" on the Macbook, it will still behave like this.

This is very annoying for several reasons, mostly because the Macbook does't seem to be very good at switching BT audio off when no audio is playing, which results in my headphone's battery being empty pretty much every day now.

Does anybody else have this problem? Any solutions?

  • Is turning off your headphones not an option?
    – Tuesday
    Commented Dec 28, 2016 at 16:12

2 Answers 2


You can consider setting your Mac not to auto-connect to Bluetooth headphones, using this command in Terminal:

sudo defaults write /Library/Preferences/com.apple.Bluetooth.plist DontPageAudioDevices 1

This will not interfere with Apple Magic Mouse, Keyboard or Trackpad. Only audio devices will not be auto-connected.

  • Unfortunately this does not work, the Macbook still behaves as before and auto-connects to the headphones :-(
    – BlackWolf
    Commented Dec 28, 2016 at 11:18
  • @BlackWolf You can try to make your Mac forget the headphones?
    – Panda
    Commented Dec 28, 2016 at 11:19
  • Yes, that is the only solution I have so far. This, of course, is not really a good solution because I have to re-pair every time I want to use the headphones on my Macbook. It is particularly annoying because everything worked perfectly before the last macOS update.
    – BlackWolf
    Commented Dec 28, 2016 at 11:20
  • @BlackWolf I'm not sure why it didn't work, maybe you need to restart your Mac or Bluetooth?
    – Panda
    Commented Dec 28, 2016 at 11:21
  • 1
    I believe this no longer works as of Big Sur
    – Adi
    Commented Aug 1, 2021 at 7:12

There's a solution I found on Reddit that work for me:

I turn off bluetooth when I don't need it and changed my workflow so that I don't need to use bluetooth devices on my macbook anymore.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .