4

I just updated my 15 inch macbook pro retina 2014 model from OSX El Capitan to Sierra (10.12.2) and have noticed an ugly problem. It appears when I press and hold the F1-F2 (screen light +/-), the F5-F6 (keyboard light +/-) or the F11-F12 (volume +/-), the whole system becomes unresponsive for an amount of time proportional with how much I hold the button pressed. In the activity monitor I can see when it recovers that the WindowServer jumped to 100%+. This used to work perfectly on El Capitan, with normal behaviour(incremented/decremented the values until limits 0-16 bars on screen). I will file a bug report on Apple forum as well.

EDIT: I also posted on Sierra forum here. Dont know where else to report this so Apple engineers can see and fix it.

  • Download the latest Sierra Combo Updater and see if it helps. – IconDaemon Dec 28 '16 at 3:06
  • @IconDaemon I just tried to install it and the installer says that the volume does not meet the requirements for this update. I am running 10.12.2 so I don't see what requirements I don't meet. Also the update change logs don't say anything about this bug I have. – androidu Dec 28 '16 at 13:33
  • To report the bug to Apple engineers, go to bugreport.apple.com. – jksoegaard Dec 28 '16 at 13:58
  • You should be aware that Apple Discussions are rarely, if ever, visited by Apple employees. The problem you're experiencing appears unique and, to me, indicates to me a need to reinstall macOS. This page shows you how to boot from the Recovery partition – IconDaemon Dec 28 '16 at 14:07
10

Wow I accidentally debugged this myself.

It seems after all that my problem was actually a side effect caused by the real issue which was: macOS Sierra changed how it handled defaults write NSGlobalDomain KeyRepeat -int 0, it no longer supported a zero value, and I had it changed to zero in Yosemite or El Capitan to make the cursor advance faster. To reset it back to normal parameters I changed the keyboard typing delays in the System Preferences > Keyboard back to fastest (both sliders were dragged to the left sideenter image description herecheck using $ defaults read NSGlobalDomain in terminal enter image description here, most likely cause I upgraded from El Capitan and something changed in Sierra, and the keyboard was queueing input events as fast as possible, so the WindowServer process hogged the CPU like crazy) and now my initial problem is gone.

Maybe I should change the title of the question so that others can find this solution..

  • 1
    Thanks so much for sharing the solution! Had the same problem on High Sierra. It seems it's even worse there, as I had no problems before the update. – joe776 Nov 18 '17 at 11:40
  • 1
    So the fix is to push the sliders to the right? I am in the same boat as you I set the values to 0 before and now windows server is going nuts. – Yeshwanth Venkatesh Feb 7 '18 at 20:10
  • @YeshwanthVenkatesh that is correct. Slide them both to the right and it should fix the issue. – androidu Feb 7 '18 at 21:24
  • 1
    Got the same problem - set to 0, updated to Sierra. WindowServer going craaazzzzyyy. Thank you! – Keeprock Apr 13 '18 at 10:48
3

I had the very same problem after upgrading to macOS High Sierra 10.13.6. My 2010 MacBook Pro hangs between 2-5 minutes completely. If MacBook returns to normal, Activity Monitor shows exactly the amount of CPU usage for windowserver process as the hang time.

I changed the keyboard settings to fast (both sliders to the right) and the problem became worse. Then a I did the opposite, (changed both sliders to the left) and the problem was gone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .