My mid-2015 MacBook Pro (Sierra 10.12.2) skips the login screen when waking from sleep, it goes straight to my desktop.

I have my System Preferences set to require my password 1 minute after being put to sleep but it doesn't seem to be working.

Anyone have an idea of what the problem might be?

  • I have seen the same problem on my mid-2014 15" mbp after update to sierra 10.12.2.
    – ken2s0
    Jan 13, 2017 at 17:22
  • 1
    I have the same issue. MacBook Pro Late 2013. Up to date BigSur. Waking up after sleep doesn't ask for a password but in a random manner. Sometimes it asks, sometimes it doesn't. It's certainly not a trustworthy mechanism when it comes to security... On the other hand, it asks 100% of the time after locking the screen. Jun 11, 2021 at 7:06

7 Answers 7


Not sure if you set it in the correct place, but the setting should be at:

  1. Choose Apple menu > System Preferences, click Security & Privacy, then click General.
  2. Select “Require password… after sleep or screen saver begins.”
  3. Click the pop-up menu and choose the time that passes before a password is required.

Source: OS X Yosemite: Require a password after waking your Mac

System Preferences screenshot

  • 3
    OP already said they have "set to require my password 1 minute after being put to sleep but it doesn't seem to be working".
    – grg
    Dec 28, 2016 at 12:51
  • 1
    Instead of 1 minute, try out "immediately after sleep". Does it work?
    – user136834
    Dec 28, 2016 at 12:54
  • 2
    That seems to work if I put the mac to sleep and try to start it up again immediately after but if I leave it sleeping for any extended period of time and come back to it, it'll open to my desktop again and skip the login page. Dec 29, 2016 at 11:54
  • I thought it may have been bluetooth related so I also unchecked the "Allow Bluetooth devices to wake this computer" option in the System Preferences but not luck there either! Dec 29, 2016 at 11:58
  • Is it modifiable from command line? Nov 15, 2017 at 6:50

I found that I was able to fix this problem on 10.12.6 using the following steps:

  1. Set "Require password" to "immediately".
  2. Lock the screen or put the machine to sleep.
  3. Set "Require password" back to your preferred time delay (1 minute).

Steps I did to make laptop lock as intended.

  1. Require Password > Immediately
  2. Apply and close that setting window, quit "Settings"
  3. Unplug USB device before initiating Lock
  4. In my case it was a USB Headset that was preventing Lock
  5. Enjoy computer being locked.
  • 1
    Thank you! In my case it was not the usb but regular earphone in audio jack. I removed earphone, locked the machine and it was asking password. Now even there is one attached it works as expected.
    – artuc
    Apr 30, 2018 at 7:41
  • Where is the require password immediately option? Mar 7 at 22:23

OS X High Sierra

  1.  menu > System Prefrences > Users & Groups
  2. Click Login options at the bottom of the sidebar
  3. Settings might be disabled. Unlock them (by clicking the lock at the bottom) to make changes.
  4. After unlocking, set Automatic login to "Off"

Settings Login Options Enable settings Turn off Auto login


I had to reset the SMC. It's really simple, depending on which mMac you have:

  1. Unplug Mac from the power supply
  2. Press the Ctrl+Opt+Shift+Power buttons all 4 together for at least 10 second then release
  3. Startup again and it worked for me

Resetting the SMC clears a lot of problems but make sure you have your passwords for your email accounts as it resets them as well.


I had a similar issue. All of the above were very helpful. I also found these two steps to be effective for me, albeit with minor setbacks. It's worth a double check if the above is still not working.

  1.  menu > System Preferences > Energy Saver

  2. Make sure the option Wake For Network Access is Unchecked.


Resetting my NVRAM (PRAM) seems to have solved this for me. Had this problem with macOS 12.6.6 and 12.6.7 on my Intel iMac.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .