4

I just installed the latest patch for Sierra, so am now on 10.12.2. Post-upgrade my pointer controlled through trackpad runs very slow when I open the laptop. I can fix it by opening System Preferences -> Trackpad -> Point & Click, and just moving the "Tracking speed" slider a notch and then back to where I want it. But the fix doesn't seem to persist, so I have to do this every time I wake the machine. Does anyone know how to fix the issue permanently?

Update: using a mouse works fine regardless of trackpad state. Further, opening a full-screen application resets the trackpad back to being slow, so it's not just when the computer goes to sleep :(

  • I have the same issue but for me the trackpad speed changed by itself after connect to the external monitor via HDMI with USB-C adapter. – wint Dec 27 '16 at 4:31
  • also having this issue; no suggestions here have worked so far – Saad May 3 '17 at 0:52
2

I would try resetting both the SMC and PRAM/NVRAM.

SMC

The instructions for resetting the System Management Controller (SMC) will differ depending on whether your computer:

  • runs from a built-in battery?
  • runs from a removable battery?
  • can only run from power off a wall socket?

Since you haven't specified your computer I will provide the instructions for all three possibilities.

For MacBook Pros, MacBook Airs, and MacBooks where you can’t remove the battery on your own (i.e. it's a built-in battery), here’s what you do:

  1. Shut down your computer
  2. Keep the MagSafe adapter (or power cable) plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

For MacBook Pros, MacBooks etc that you can remove the battery from, here’s what you do:

  1. Shut down your computer
  2. Disconnect the MagSafe plug (power cable) from the computer
  3. Remove the battery
  4. Press the power button for 5 seconds and release
  5. Put the battery back in
  6. Reconnect the MagSafe cord (or power cable)
  7. Turn your computer back on with the power button

For iMacs, Mac Pros, Mac Minis, etc that only run from a power point in the wall

  1. Shut down your computer
  2. Unplug it from power
  3. Press and hold the power button for 5 seconds
  4. Plug it back in and turn it on.

PRAM/NVRAM

Older Macs had what's called Parameter RAM (PRAM), newer Macs use Non-Volatile Random-Access Memory (NVRAM). Regardless of what Mac you have, the instructions for resetting this are as follows:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. mouse speed, time and date/timezone, etc).

  • 1
    Hey, thanks for the reply. I have a late 2013 MacBook Pro. So, I reset the SMC, but can't seem to reset the NVRAM - I have a firmware password, and every time I try and hold command option p r it presents me with the firmware password screen rather than restarting the machine. It then boots me into the MacOS Utilities for disk recovery and that sort of stuff. Any idea how I can do the reset while having the firmware password, or do I need to temporarily remove it? – Matthew Herbst Dec 28 '16 at 19:25
0

I have the same problem. Note you don't need to move the Tracking Speed slider to fix the issue, just tapping on it, in its current setting is enough to temporarily fix the issue.

I have the problem anytime I load Starcraft II or the Razer Synapse software.

I tried resetting the SMC, NVRAM, and deleting the ~/Library/Cashes. None of those suggestions work.

  • Good call on not needing to actually move the slider, thanks! I also have Razer Synapse on my machine. I'll try playing around with it to see if it changes anything. – Matthew Herbst Jan 1 '17 at 18:36
0

I have Razer Synapse 1.66.9 installed as well running on Sierra 10.12.3. Razer profile changes or any setting change in RS resets the trackpad tracking speed. Reported the issue to Razer but I don't expect any solution from them soon. I didn't have this issue with El Capitan. I created this little AppleScript to fix the issue temporarily. I still have to figure out something that triggers this script.

tell application "System Preferences"
    reveal pane "com.apple.preference.trackpad"
end tell
delay 0.3
tell application "System Events" to tell process "System Preferences"
    try
        set value of slider "Tracking speed" of tab group 1 of window "Trackpad" to 5
        display notification ("Sensitivity set!")
    on error theError
        --An error occured
        display dialog ("Sorry, an error occured while altering Keyboard and Mouse settings:" & return & theError) buttons "OK" default button "OK"
    end try
end tell
-1

Empty your Mac’s cache, by using the Finder window and selecting Go to Folder in the Go menu. Next, type in ~/Library/Caches and hit enter to go to that folder and empty it. 2) Try holding down command + option when you launch the app. 3) Another explanation could be an issue with your Mac’s security settings. Go to the Security and Privacy system preferences, and check the Allow applications downloaded from: Anywhere setting. 4) Try resetting your computer’s PRAM. To do this, shut down your Mac and turn it back on. As soon as you hear the startup sound, hold down command, option, P and R. Hold these down until you hear the computer restart and the startup sound playing for a second time.

  • 1
    I'm not sure that the security setting recommendation is accurate. It doesn't fix the issue, but even if it did, is a dangerous thing for the average user to be setting, and would point to a much larger bug in the system. – Matthew Herbst Dec 28 '16 at 19:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .