1

I'm out of ideas... Tried every suggestion I could find on the net, but nothing worked. Hoping someone here has a different idea.

The situation

I'm trying to reinstall OS X (Lion, or higher -- which version doesn't matter to me right now) on a Macbook Air, 11-inch, Late 2010 model.

The machine came with OS X Lion pre-installed, and has been upgraded up to El Capitan while I used it.

I recently decided to give the MBA away. Before doing so, I erased the default system/home partition with Disk Utility in Recovery Mode.

I have now been trying to re-install OS X on the MBA, but didn't succeed.

Things I tried already

  • Turning on the machine, i.e. regular startup: Bootup stops at question mark screen. No surprise, since the system partition has been erased.

  • Turning on with cmd-R, i.e. regular recovery mode. No visible progress for about 30 seconds, i.e. grey screen, then automatically switch to Internet recovery mode. Seems to suggest that there's no recovery partition, or it's not recognized, right?

  • Turning on with cmd-option-R, i.e. using Internet recovery mode directly. Mac OS X Utilities menus load, no problem here. Selecting option 2, "Reinstall Mac OS X", I am offered to install OS X Lion 10.7 (the original OS the machine was shipped with). Pressing "ok" is followed by message "To download and restore Mac OS X, you computer's eligibility will be verified with Apple". "ok", followed by progress report "Loading Installation Information", then dialog to confirm license agreement, then dialog to select installation disk. After that, I am asked to sign into the App Store. This step is not optional in my case, i.e. I cannot skip the app store sign-in. Once I sign in, installation fails with error message: "This item is temporarily unavailable. Please try again later."

  • Checking Disk Utility, I see there's no recovery partition. Not 100% sure why, since I didn't erase it, but given that I got the MBA from someone else as well, it is possible that partition was erased earlier.

  • Last thing I tried: Recovery Disk Assistant on my working Macbook Pro to create recovery USB. Using USB on MBA at boot up leads to the regular boot up progress bar going about halfway, then stopping at an error screen (box with an "X" inside). Perhaps because the computer I used to create the USB runs El Capitan, while MBA came with Lion.

Summary

Trying to re-install OS X on Macbook Air after erasing default system partition.

Recovery partition missing, so I have to use Internet recovery.

Internet recovery installation fails as follows:

(1) I am forced to sign into app store when reinstalling OS X Lion (weird, since other people suggest app store sign-in is not necessary when reinstalling original OS).

(2) After signing in, I get the error "This item is temporarily unavailable."

  • It's weird as I restored my MBP using IR and installed Lion without any issue few weeks ago. Did you try to create a bootable USB disk as described on Apple Support site support.apple.com/en-us/HT201372 ? – Pratik Dec 27 '16 at 7:00
  • @PratikaRana Didn't try the terminal command yet, will give it a shot. – Bert Zangle Dec 27 '16 at 23:14
2

The best thing you can do is to create a bootable USB disk with any new OS X of your choice. Please see Apple support page to create a bootable disk. I guess, it will solve your installation issues with your MBA. https://support.apple.com/en-us/HT201372

  • 3
    One thing that Apple support article doesn't mention is that the USB disk must be formatted with a GUID partition table (GPT, sometimes called GUID partition map). Flash drives often come formatted with master boot record (MBR) instead, so use Disk Utility to erase the disk first, and choose GPT for the partition scheme. – Gordon Davisson Dec 27 '16 at 7:17
  • Thanks, will try that. I take it that using the method you linked to (createinstallmedia from Terminal) is different than what I tried already (using the standalone app Recovery Disk Assistant). – Bert Zangle Dec 27 '16 at 23:13
  • @BertZangle I have tried the Apple way many times in past years and it works flawlessly. – Pratik Dec 28 '16 at 3:37
  • Confirming that your method works, as opposed to using Recovery Disk Assistant which didn't work. Disk Utility on USB --> Erase, settings: GUID and Mac OS Extended (Journaled) --> createinstallmedia on /Applications/Install macOS Sierra.app --> Booting from USB & installing Sierra on MBA11. Thanks a lot for the suggestion, marking as 'answered' now. – Bert Zangle Dec 28 '16 at 19:33
  • 1
    @BertZangle The Recovery Disk Assistant works by cloning your startup disk's existing Recovery HD partition to the flash drive. If you don't have a standard setup (i.e. Recovery HD partition and regular startup volume, or your startup volume is in Core Storage mode, it won't work right. Since Core Storage is now the default setup, it's mostly useless in practice. – Gordon Davisson Dec 28 '16 at 23:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .