1

Safari always tries to autocomplete websites to only be the host, with no path (nothing after the ".com/" part).

That is, when I type "ever"... the first option is "evernote.com", when the only site I ever actually visit is "evernote.com/Home.action". I want it to go directly to that one. I don't want to have to press "down" once.

Chrome does this the way I want, but I'm trying to move from chrome to safari (chrome eats battery).

This is a brand new MacBook Pro, and I have no bookmarks, deleted all history, iCloud is disabled (I haven't even signed in with an appleID yet), etc. I can get the "evernote" recommendation to disappear when I delete everything, but as soon as I visit ONLY "evernote.com/Home.action", the base url will start appearing above the action I actually want.

Similar problems ~9 years ago here, can't seem to find a solution. I've been looking for hours now: http://ask.metafilter.com/76691/How-to-turn-off-Safaris-improved-autocomplete

This is what happens, :(

1

Perhaps showing full website address can solve your issue:

Safari->Preferences->Advanced->Smart Search Field: Show full website address [check]
  • thanks for the answer, but doesnt solve what i was going for (that option just seems to hide the path to improve readability - not actually change autocomeplete behavior). Not sure if what i want is even possible in safari at this point :P – supername Jan 8 '17 at 21:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .