I have a 2016 MacBook Pro, with Touch Bar, running macOS Sierra (10.12.2). I am trying to install Windows 10 to a new external SSD using Boot Camp Assistant.

I have read numerous methods detailing how to complete this installation, including this great thread.

Under macOS Sierra, this seems to be different. For example, when I run Boot Camp Assistant in macOS Sierra, the first screen is the standard introduction screen, and the second screen jumps right into the partition screen. I have no ability to download any software, or even to select my target drive.

macOS Sierra Boot Camp Assistant

This is as far as I have gone because I do not want to modify the partition of my internal drive.

Also, here is a screenshot of Disk Utility where you can see my external SSD currently partitioned and ready. I am wanting to install Windows 10 on the 100GB W10 partition (MS-DOS). The drive is plugged in, but Boot Camp Assistant does not recognize it (or allow me to select it as an install destination).

Disk Utility

Any ideas?

Update 1: I tried to get around this problem by trying to ignore Boot Camp Assistant altogether and just installing WindowsToGo on my SSD. No luck. I eventually thought the problem might be because the SSD is split in 2 partitions, and maybe Mac doesn't like that. So I wiped the whole drive and installed WindowsToGo on the single partition using this guide. Everything appeared to install fine, but the MacBook will not recognize the drive when booting.

Update 2: I thought I might be doing something wrong, so I tried using AAOMEI Partition Assistant Standard (which automates the WindowsToGo installation). Same problem. Everything on the drive looks fine, but the Mac won't recognize it as a bootable drive.

  • Were you able to fix this problem? I just bought a Samsung T3 for this purpose and seems unbootable Commented Mar 21, 2017 at 4:28

2 Answers 2


It seems to be a bug (or feature) in 10.12.2 that macOS will not recognize an external SSD when booting.

I have installed Win10 via WindowsToGo several months ago on an external SSD, when my macOS version is 10.11. Everything was fine when I upgraded to 10.12 and 10.12.1, but at the stage of 10.12.2, the external disk cannot be recognized anymore during booting.

At current no solution is provided by Apple. I suggest that you roll back to 10.12.1 or earlier versions if you are eager to do the installation.

EDIT: I happened to boot the external SSD successfully several times for 10.12.2 by cutting off all the network connections (wireless and ethernet).

  • How does that work? I get to the startup manager screen but even if The wifi is not connected I never see the device Commented Mar 21, 2017 at 4:29

Came across a post with the solution how to just download the drivers here. From the application menu choose "Action" and "Download Windows Support Software".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .