I have a Macbook Pro Retina 13" (Early 2015) and I have a bootcamp partition with Windows 10 installed in it. Also, there is an Ubuntu Linux on another partition, so it’s a triple boot computer. I’m not using rEFInd, but the stock startup manager instead. I am switching operating systems using the option key at boot and it was all working fine until recently.

The problem I am facing right now is that every time I turn my laptop on or try to switch operating systems using the option key the drive selection screen takes a long time to appear, like literally 20 to 30 seconds. This is not really normal because it used to be 2-3 seconds. Also, once the drive selection screen appears the mouse pointer just doesn't work or sometimes work un-reliably or extremely slowly. I can use the arrow keys in the keyboard to select the drives but the response is just too slow. Once i hit an arrow key it takes 15 to 20 seconds to register and move the selection, sometimes it doesn't respond at all. And then finally when I hit return it takes another half a minute or so to load up the boot sequence. After that the operating system works just fine. I also have GRUB on one of the partitions for loading Linux. When I select Linux in the Startup Manager drive selection screen the GRUB console starts and it works very slow as well: I have to type commands and wait 10 seconds for the letters to appear on the screen. Ubuntu itself works just fine.

Could anyone please point me out on any possible causes of the problem? I will provide any additional info if you request.

There is a very similar question, but it was solved by completely reinstalling everything. However I would like to find the real cause of the problem to be able to prevent it in future (my setup is kinda complex, and I don’t want to reinstall everything just to face this problem again in a month or two).

Update 1: I have tried to reset NVRAM and SMC with no result.

Update 2:

I don't remember what exactly preceded the happening of this issue, but here are my thoughts:

  • Perhaps this happened after I installed "Paragon NTFS for Mac OS X" or "FUSE for OS X". I have both installed now and I use them to access Windows and Linux partitions
  • Maybe this happened after the hibernation of the Windows partition
  • It's possible that the issue happened after the system update, but it definitely happened long before the major update from El Capitan to Sierra.
  • The issue takes place not only in Startup Manager, but in any software that is running before the OS starts booting. Recovery, Hardware Diagnostics, Startup Manager, and even GRUB (which is on it's own partition) all work extremely laggy. If I don't hold any keys and let the macOS boot normally, then everything that occurs before the apple logo is taking much more time than it should. As soon the logo and progress bar appear - the lags are gone. Same with other OSes.

The operating system is macOS Sierra 10.12.1 along with Windows 10 and Ubuntu. I have tried to run Apple hardware diagnostics (by holding down the D key at startup) and got this message:

There may be an issue with the SD card reader. Reference code VDC001

I've noticed that when I bought the laptop this test passed without any issues.

I also tried to boot in Safe Mode, but nothing happened, except that the macOS GUI was glitchy and choppy while in safe mode.

Update 3:

I have found an interesting behaviour. The issue is gone just for one boot whenever I do these steps:

  1. Boot into Ubuntu Live USB stick
  2. Choose "Shut down" -> "Restart" from Ubuntu system menu
  3. The subsequent boot goes without slugging, seems like the issue is gone, no matter which OS I choose this time.

But the issue is back at the next boot. Also, if I choose to "Shut down" at the step 2, the subsequent boot is slugging like every other. What could be so special in Ubuntu live stick, that it cures the issue for one time?

  • Is the internal drive an HDD or a SSD? – IconDaemon Dec 23 '16 at 23:11
  • The internal drive is SSD 512 Gb. Do you think this may be an issue with hardware? – Anton Reshetnikov Dec 25 '16 at 8:52
  • 1
    I asked for clarification. I'm assuming this is the original internal SSD. Have you zapped NVRAM, PRAM, and SMC? This may help. As a last resort, have you backed up everything, reformatted the SSD & reinstalled the various OS's? – IconDaemon Dec 25 '16 at 15:37
  • Resetting NVRAM and SMC did not help, unfortunately. I don't want to reformat and reinstall everything, because I have very complex setup. Also there is no guarantee that the problem will not pop up later after the reinstall. – Anton Reshetnikov Dec 30 '16 at 18:00
  • 1
    I have a number of questions that will help us troubleshoot your problem. (1) You say it was all working fine until recently, so is there anything you can think of that changed around the same time: (a) Any new hardware? (b) An OS upgrade (or update)? (c) New software? (d) Anything at all that you can think of that changed at the same time (or just before) you started noticing this problem? (2) What version of macOS are you running? (3) Have you tried booting into Safe Mode for a while and then restarting to see what happens? (4) Have you run any hardware diagnostics? – Monomeeth Dec 31 '16 at 3:33

11 Answers 11

up vote 1 down vote accepted

Same issue here, noticed it in FileVault, but then realized it is there even on Boot selection section or even Diagnosis section. Disabling FileVault won't solve the issue, it will just cover it up.

I wasted a lot of time with software sides of things, reinstalling OS and all. they all didn't help. It is a Hardware issue.

I realized I have this issue once I started using SD Card reader for storing my files and extending my 128gb MBP. If SD Cards goes in, even for 1 second, and then take it out, boot is going to be slow until I do a NVRAM reset. Apple care didn't find any issue first time but second time they admit there is a hardware issue in my Macbook and they replaced it. I will report back issue returned.

You need to bring it to Apple care, and describe the issue in detail. I had to print a A4 paper with a detailed description (told them issue happen when put in a sd card and then take it out) and screenshot of diagnosis page showing SD Card error in diagnosis boot page (because for some reasons, it was randomly showing that error and apparently when I give my Macbook for first repair, it passed test 100% successfully) Reception who receive my Macbook, she didn't really reflect things I told to her to technician. She even typed issue of my macbook as "Booth up slow", you get the idea.

Yeah, you need to bring it to apple care for hardware fix and bring enough documents to prove them it is hardware issue.

  • Thank you for this suggestion. I was talking to a technician two weeks ago and he suggested the same thing, because he already stumbled upon the same issue with other customers. I don't know how soon I will have time and money to try to fix this again though. – Anton Reshetnikov Feb 18 '17 at 21:06
  • Today I've received my Macbook Pro 13inch 2015 back from Warranty and they have replaced I/O Board. Issue has been fixed. – Armin Nikdel Feb 22 '17 at 1:04
  • 1
    So I finally brought my Macbook to repair service. Replacing the I/O board solved my problem as well. It looks like there is a percentage of Macbooks with the same defect. – Anton Reshetnikov Mar 20 '17 at 19:50
  • Does it make us eligible to make a class action lawsuit? – Armin Nikdel Mar 22 '17 at 2:35
  • 1
    I have no idea :) I bought my macbook from someone on Ebay, and those guys who replaced the I/O board are not Apple service. So I doubt I can do something here. – Anton Reshetnikov Mar 23 '17 at 8:31

Important: Do not use paragon crappy hfs+ implementation, since windows will at some point cripple your system partition! If you need HFS+ access on Windows use macdrive

First boot into single user mode (hold the S key during boot) and after some dmesg messages you should see a command prompt, do:

fsck -fy / and see if there are any errors. After the run type reboot if there were any changes or exit if nothing needed repairs.

If you have anything on your USB ports when booting, take it out - entry scan take long, especially if its some legacy USB devices. Your problem seems to be in entry scan part of booting (searching for bootable partitions of type EFI with bootflag) and/or with a device that is causing read errors. To get to the bottom of it:

Try the following first - assuming that disk0s1 is your ESP aka EFI partition, open up terminal and:

Let's check the bless output:

step 1 sudo bless --device /dev/disk0s1 --setBoot --nextonly --verbose

paste the output somewhere please so I can take a look on it. Reboot after that and see if the behaviour changes- might also help.

step 2 Let's get rid of any NVARS with boot entries and make sure they are cleared:

Launch any kind of linux from EFI (meaning booting not through MBR) - you can take Ubuntu live CD for that, after booting it, launch the terminal and do: sudo efibootmgr -v - if you get an error of not having efibootmgr command do sudo apt-get install efibootmgr (should install this package)

Once you got the efibootmgr -v (keep the output somewhere for later review)

you should see something like this:

[root@localhost ~]# efibootmgr BootCurrent: 0004 BootNext: 0003 BootOrder: 0004,0000,0001,0002,0003 Timeout: 30 seconds Boot0000* Diskette Drive(device:0) Boot0001* CD-ROM Drive(device:FF) Boot0002* Hard Drive(Device:80)/HD(Part1,Sig00112233) ...

Use the hex value to delete each entry with -B -b flag:

efibootmgr -B -b 0001

efibootmgr -B -b 0000

until it cries that there are no entries anymore. Don't worry about it, those variables are set to default each time if they are not set by your macbooks firmware - and that's what we want, we can see if the default boot device is having scanning issues or scanning issues are created by obsolete entries.

Let me know when you do this - in most cases you will be done at this point, if you won't - let me know here and we can look into it further.

I strongly recommend to use refind as bootmgr, its not native, but it does not look for Timemachine and does not calls home through wifi ;) also it gives you better options in case of troubles and you can still can use the native apple's EFI boot, refind does not care about it - its just a change in your boot order list so refind is on it. It also loads some .efi drivers for extra access and functionality at boot time, so far I know they don't collide with apple firmware.

short update: You can use nvram -p and nvram -c to clear nvram directly in macOS from terminal

  • Thank you for trying to help! I'm not using any HFS+ drivers for Windows. I've done everything like you said, but still the problem persisted. Here is the output of all commands (also, "diskutil -p"): pasted.co/09cd8cd7 The "fsck -f" command did not find any errors. Are there any EFI boot logs that I can check? – Anton Reshetnikov Dec 31 '16 at 16:01
  • Ok, "something" is choking your boot process, as for EFI bootlogs I frankly don't know if apple's efi boot manager has any means to log what it does- but this is a good question. You can re-format all EFI partitions, starting with disk0s1, there is not really anything of importance there, still make a image-backup first, its only 200mb. Do the backup with linux, diskutil wont show you the efi partitions, even when you force-mount them, so you cant make an "image from..." through it- but diskutil list will list EFI's. You might have, some leftover's or FS errors there are freezing it. – PJJ Dec 31 '16 at 16:17
  • Do install refind first though and see if it's also slowing down and is hanging when loaded - will be a clear indicator that entries scan is slowing you down – PJJ Dec 31 '16 at 16:21
  • Also, are you using any external screen? Since you wrote that grub is also slugging etc. this might be graphics related- but it's a wild guess – PJJ Dec 31 '16 at 16:23
  • I had something similar once, loading the bootscreen took like 1 minute or more. I found that I had some errors in partition tables after adding / removing or whatever I did, one of the drives had a bad gpt table and bootmgr tried to read entries on it and well... it was taking it's time trying, so I checked all drives partition tables, did found errors, auto-corrected those with gparted, rebooted and it was all honey again. – PJJ Dec 31 '16 at 16:31

Troubleshooting is often a process of elimination, so it can take time and patience. We'll have to work through these steps one at a time until we can identify the cause and resolve it.

1. Software

As a starting point, I would update macOS Sierra to 10.12.2 (it's been out for about two weeks now).

I'd also ensure you have the latest version of Paragon NTFS for Mac OS X and FUSE for macOS installed.

Once you've ensured you have the latest versions installed, let us know how you go.

  • Updated the macOS to 10.12.2 and FUSE to the latest version. Paragon NTFS was up to date. Still no luck. Are there any EFI boot logs that I can check? – Anton Reshetnikov Dec 31 '16 at 15:46
  • you're welcome for that close bracket :D – owlswipe Dec 31 '16 at 15:54

This problem depends on a firmware issue that prevents the I/O board from working properly.

I suggest to upgrade to MacOS Sierra 10.12.4, which contains a firmware update that address this issue.

  • 1
    Welcome to Ask Different! Please refrain from adding comments in the Answer section, this is for answers to the questions. Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. – fsb Apr 14 '17 at 21:04
  • I've edited my answer. Better now? – solitone Apr 15 '17 at 5:35

Based on the information provided in the updates and the comments, there appears to be a problem with the SSD; either a physical problem or a problem with the partition table. Especially since the "problem went away" when you booted Linux.

When you turn on your Mac, it loads the EFI from ROM. Basically, long before any software or addins like FUSE or MacDrive or Paragon can be loaded, it's loading up drivers to read the hard drive. Note: It only knows how to read HFS+ and MBR; it has no clue how to read NTFS.

enter image description here

If/when you press Option during boot, it brings up a GUI boot manager. It will scan the available volumes for a header that tells it what type of boot partition is available. This is the list you get to choose from.

If you notice, before it boots the volume, it writes the boot volume info to NVRAM. This is why it worked after your Linux boot; it had clean volume info.

Also if you are running Boot Camp, you aren't booting directly to to the NTFS partition directly, you are using a boot loader (Boot Camp) to boot Windows. If you have multiple OSes like macOS, Linux, and Windows, you are probably using a different boot loader like GRUB.

enter image description here

Now, if you were to issue the command diskutil list you would see that it only displays a GPT header for Boot Camp, not the actual NTFS Boot Camp partition itself. EFI can't boot NTFS; only HFS and MBR - this is why we need the boot loader.

enter image description here

Diagnose the issue

For this procedure, you are going to need another bootable medium like an external USB drive or a USB flash (like your Linux USB, but macOS).

The way you diagnose if your SSD is the problem is to remove the SSD. It's a fairly simple process of removing the back cover and removing the module. iFixit.com has an excellent guide on how to do this.

You won't need to put the back cover back just yet; just make sure you work on a clean, flat, non-conductive surface. (In other words, don't work on a dirty, metal table or on a bed or pillow)

enter image description here

Once removed, insert your USB drive/flash and procede to boot. If the problem goes away, the issue is with your SSD. If it remains there is an issue with your controller/logic board. It's time to get it looked at

To diagnose the SSD.

For this procedure, you are going to want to make sure you have a full backup of your drive.

Once you are sure your SSD is backed up, wipe your SSD and do a clean installation of macOS. The the problem persists, your SSD is most likely faulty. If not, then it's most likely there was a corrupt GPT table. Do a full, clean install of both macOS and Boot Camp. Then do a restore your data from Time Machine (backup).

Once you have determined whether it's your drive's partition table or a physical problem, you can proceed from there.

  • Thank you for the insightful post. Is there an easier way to say if the GPT table is corrupt and how to fix it? Maybe some software tool? Also, if the bad NVRAM contents lead to the problem, maybe there is a way to force correct values to be written into it? – Anton Reshetnikov Jan 5 '17 at 21:06
  • The problem is two fold - if it's physical, there won't be a fix other than replacing. If it's just corrupt, it's tough to know exactly where the issue is to fix the GPT table. – Allan Jan 5 '17 at 23:34
  • I forgot to mention...regarding the NVRAM values, it's not so much "knowing" the correct values to write, but the values it gets from reading the header info. If that info is corrupt, it will be corrupt in NVRAM. The fix will be to address the corrupted info on the drive. But before focusing on the drive, we should eliminate it from the equation to see if it actually is the drive – Allan Jan 6 '17 at 13:39
  • You don't need to take your mbp apart to diagnose a SSD, SMART system can give you all the information you need- I strongly suggest to take a close look on your log in Ubuntu, or check log stream --style=syslog --level=default for a while and/or search it for clues. GPT can be easily fixed in most cases, it has extra copy of its header, can be easily replaced/reedited even if its fried. @Allan: there is no MBR with GPT, a partition scheme is either GPT or MBR, PMBR is a legacy 5th wheel within GPT- and macOS is an efistub- I don't know in which point it would care about MBR in a 2015 mbp. – PJJ Jan 7 '17 at 9:20

I understand that the issue could hapeen with update process, Paragon NTFS or some boot error, but I had similar experience on early 2015 MacBook Pro fixed up by disabling full disk encryption in recovery. After re-enabling it everything worked well. I recommend fixing disk permissions in recovery, too.

  • Just wanted to let you know that you can't fix disk permissions in macOS Sierra. The option is gone from Disk Utility and, unlike El Capitan, it is no longer available via a Terminal command. While it is possible to still work around this to repair them, the effort involved is, according to Apple, no longer worth it as macOS Sierra regularly checks/repairs permissions on its own (e.g. during software updates, etc). – Monomeeth Jan 3 '17 at 22:59

A simple test - can you boot from SD Card? Just install a small OS on it, and, after pressing option, select the SD Card. If your Macbook has an IR receiver, make sure to cover it with some black tape, sometimes these things break and give constant signals which result in the behaviour you describe.

  • There is no IR receiver. I can easily boot from a USB stick, but never tried to boot from SD card. However, the SD card reader works fine when I mount it in the macOS to copy photos from it. – Anton Reshetnikov Jan 5 '17 at 12:50
  • Just read your updated info. The ubuntu part is interesting. What I'd try is to install gdisk from sourceforge sourceforge.net/projects/gptfdisk/files/gptfdisk/1.0.1/… run "diskutil list" and then run gdisk on your partitions "sudo gdisk /dev/disk0". You can see the repair options here rodsbooks.com/gdisk/repairing.html if you find errors. Make a backup! – user2707001 Jan 6 '17 at 15:21

I have the same issue. Refit takes forever to load. I have also tried the regular reset SMC, PRAM, etc. I am triple booting my system with archlinux and windows 10. A few other people have this problem with the early 2015 macbook pro as well. Which SSD do you have? I have the 512 Gb version. I really dont want to start over again and reinstall everything.

Here's a similar link: OSX Startup Manager (Boot drive selection screen) slow/un-responsive in Macbook Pro (early 2015)

There is simple way to verify if you have the Bad SD-I/O Card problem.

Just hold down the D Key on power up and it will run diagnostics.

I brought mine to the Apple Store and that is the first thing they did and the SD Card popped up with an error. Even though my SD Card worked fine.

The Part cost about $42.00 New

They installed it the same day (after waiting 1 day for the part to arrive).

Total cost was $124.00 Part + Labour + Tax

There are places on the net you can buy the part new or used and replace yourself. I'm fairly technical and done repairs like this but I decided to pass on this one. Involves removing CPU Heatsink and fan and quite a few small connectors.

You can see Videos on Youtube for similar repair on MacBook Air.

iFixit has detailed description on repair for this exact laptop.

some 2015 macbook pro owner reporting the slow/unresponding issue has gone after update to the newest macos 10.12.4beta8. It is clearly a driver issue and apple has finally addressing that on their latest update.

I had the same issue and it's finally gone after the update to 10.12.4.

protected by bmike Apr 14 '17 at 22:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.